Click or drag to resize

CachedTextureCoordinatesCopyTo Method

Copies the elements of the this collection to an System.Array, starting at a particular System.Array index.

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.10
Syntax
public void CopyTo(
	Point3d[] array,
	int arrayIndex
)

Parameters

array
Type: Rhino.GeometryPoint3d
The one-dimensional System.Array that is the destination of the elements copied from this collection. The System.Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
ExceptionCondition
ArgumentNullException array is null
ArgumentOutOfRangeException arrayIndex is less than 0.
ArgumentException The number of elements in this collection is greater than the available space from arrayIndex to the end of the destination array.
See Also