Click or drag to resize

Point3d Structure

Represents the three coordinates of a point in three-dimensional space, using Double-precision floating point values.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Point3d : ISerializable, IEquatable<Point3d>, 
	IComparable<Point3d>, IComparable, IEpsilonComparable<Point3d>, 
	ICloneable, IFormattable

The Point3d type exposes the following members.

Constructors
  NameDescription
Public methodPoint3d(Point3d)
Initializes a new point by copying coordinates from another point.
Public methodPoint3d(Point3f)
Initializes a new point by copying coordinates from a single-precision point.
Public methodPoint3d(Point4d)
Initializes a new point by copying coordinates from a four-dimensional point. The first three coordinates are divided by the last one. If the W (fourth) dimension of the input point is zero, then it will be just discarded.
Public methodPoint3d(Vector3d)
Initializes a new point by copying coordinates from the components of a vector.
Public methodCode examplePoint3d(Double, Double, Double)
Initializes a new point by defining the X, Y and Z coordinates.
Top
Properties
  NameDescription
Public propertyIsValid
Each coordinate of the point must pass the IsValidDouble(Double) test.
Public propertyItem
Gets or sets an indexed coordinate of this point.
Public propertyMaximumCoordinate
Gets the largest (both positive and negative) valid coordinate in this point, or RhinoMath.UnsetValue if no coordinate is valid.
Public propertyMinimumCoordinate
Gets the smallest (both positive and negative) coordinate value in this point.
Public propertyStatic memberOrigin
Gets the value of a point at location 0,0,0.
Public propertyStatic memberUnset
Gets the value of a point at location RhinoMath.UnsetValue,RhinoMath.UnsetValue,RhinoMath.UnsetValue.
Public propertyX
Gets or sets the X (first) coordinate of this point.
Public propertyY
Gets or sets the Y (second) coordinate of this point.
Public propertyZ
Gets or sets the Z (third) coordinate of this point.
Top
Methods
  NameDescription
Public methodStatic memberAdd(Point3d, Point3d)
Sums two Point3d instances.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberAdd(Point3d, Vector3d)
Sums up a point and a vector, and returns a new point.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberAdd(Point3d, Vector3f)
Sums up a point and a vector, and returns a new point.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberAdd(Vector3d, Point3d)
Sums up a point and a vector, and returns a new point.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberArePointsCoplanar
Determines whether a set of points is coplanar within a given tolerance.
Public methodCompareTo
Compares this Point3d with another Point3d.

Component evaluation priority is first X, then Y, then Z.

Public methodStatic memberCullDuplicates
Removes duplicates in the supplied set of points.
Public methodCode exampleDistanceTo
Computes the distance between two points.
Public methodDistanceToSquared
Computes the square of the distance between two points.

This method is usually largely faster than DistanceTo().

Public methodStatic memberDivide
Divides a Point3d by a number.

(Provided for languages that do not support operator overloading. You can use the / operator otherwise)

Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified Object is a Point3d and has the same values as the present point.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Point3d)
Determines whether the specified Point3d has the same values as the present point.
Public methodStatic memberFromPoint3f
Converts a single-precision point in a double-precision point.
Public methodGetHashCode
Computes a hash code for the present point.
(Overrides ValueTypeGetHashCode.)
Public methodInterpolate
Interpolate between two points.
Public methodStatic memberMultiply(Double, Point3d)
Multiplies a Point3d by a number.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberMultiply(Point3d, Double)
Multiplies a Point3d by a number.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberSortAndCullPointList
Orders a set of points so they will be connected in a "reasonable polyline" order.

Also, removes points from the list if their common distance exceeds a specified threshold.

Public methodStatic memberSubtract(Point3d, Point3d)
Subtracts a point from another point.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodStatic memberSubtract(Point3d, Vector3d)
Subtracts a vector from a point.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodToString
Constructs the string representation for the current point.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodCode exampleTransform
Transforms the present point in place. The transformation matrix acts on the left of the point. i.e.,

result = transformation*point

Public methodStatic memberTryParse
Converts the string representation of a point to the equivalent Point3d structure.
Top
Operators
  NameDescription
Public operatorStatic memberAddition(Point3d, Point3d)
Sums two Point3d instances.
Public operatorStatic memberAddition(Point3d, Vector3d)
Sums up a point and a vector, and returns a new point.
Public operatorStatic memberAddition(Point3d, Vector3f)
Sums up a point and a vector, and returns a new point.
Public operatorStatic memberAddition(Vector3d, Point3d)
Sums up a point and a vector, and returns a new point.
Public operatorStatic memberDivision
Divides a Point3d by a number.
Public operatorStatic memberEquality
Determines whether two Point3d have equal values.
Public operatorStatic member(Point3d to Vector3d)
Converts a point in a vector, needing casting.
Public operatorStatic member(Vector3d to Point3d)
Converts a vector in a point, needing casting.
Public operatorStatic memberGreaterThan
Determines whether the first specified point comes after (has superior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified point comes after (has superior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic member(Point3d to ControlPoint)
Converts a point in a control point, without needing casting.
Public operatorStatic member(Point3f to Point3d)
Converts a single-precision point in a double-precision point, without needing casting.
Public operatorStatic memberInequality
Determines whether two Point3d have different values.
Public operatorStatic memberLessThan
Determines whether the first specified point comes before (has inferior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified point comes before (has inferior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberMultiply(Double, Point3d)
Multiplies a Point3d by a number.
Public operatorStatic memberMultiply(Point3d, Double)
Multiplies a Point3d by a number.
Public operatorStatic memberSubtraction(Point3d, Point3d)
Subtracts a point from another point.
Public operatorStatic memberSubtraction(Point3d, Vector3d)
Subtracts a vector from a point.
Public operatorStatic memberUnaryNegation
Computes the additive inverse of all coordinates in the point, and returns the new point.
Top
See Also