Click or drag to resize

Point3d Operators and Type Conversions

The Point3d type exposes the following members.

Operators
  NameDescription
Public operatorStatic memberAddition(Point3d, Point3d)
Sums two Point3d instances.
Public operatorStatic memberAddition(Point3d, Vector3d)
Sums up a point and a vector, and returns a new point.
Public operatorStatic memberAddition(Point3d, Vector3f)
Sums up a point and a vector, and returns a new point.
Public operatorStatic memberAddition(Vector3d, Point3d)
Sums up a point and a vector, and returns a new point.
Public operatorStatic memberDivision
Divides a Point3d by a number.
Public operatorStatic memberEquality
Determines whether two Point3d have equal values.
Public operatorStatic member(Point3d to Vector3d)
Converts a point in a vector, needing casting.
Public operatorStatic member(Vector3d to Point3d)
Converts a vector in a point, needing casting.
Public operatorStatic memberGreaterThan
Determines whether the first specified point comes after (has superior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified point comes after (has superior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic member(Point3d to ControlPoint)
Converts a point in a control point, without needing casting.
Public operatorStatic member(Point3f to Point3d)
Converts a single-precision point in a double-precision point, without needing casting.
Public operatorStatic memberInequality
Determines whether two Point3d have different values.
Public operatorStatic memberLessThan
Determines whether the first specified point comes before (has inferior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified point comes before (has inferior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y, then Z.

Public operatorStatic memberMultiply(Double, Point3d)
Multiplies a Point3d by a number.
Public operatorStatic memberMultiply(Point3d, Double)
Multiplies a Point3d by a number.
Public operatorStatic memberSubtraction(Point3d, Point3d)
Subtracts a point from another point.
Public operatorStatic memberSubtraction(Point3d, Vector3d)
Subtracts a vector from a point.
Public operatorStatic memberUnaryNegation
Computes the additive inverse of all coordinates in the point, and returns the new point.
Top
See Also