Click or drag to resize

Point3dLessThanOrEqual Operator

Determines whether the first specified point comes before (has inferior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y, then Z.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static bool operator <=(
	Point3d a,
	Point3d b
)

Parameters

a
Type: Rhino.GeometryPoint3d
The first point.
b
Type: Rhino.GeometryPoint3d
The second point.

Return Value

Type: Boolean
true if a.X is smaller than b.X, or a.X == b.X and a.Y is smaller than b.Y, or a.X == b.X and a.Y == b.Y and a.Z <= b.Z; otherwise, false.
See Also