Click or drag to resize

Point3d Methods

The Point3d type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAdd(Point3d, Point3d)
Sums two Point3d instances.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberAdd(Point3d, Vector3d)
Sums up a point and a vector, and returns a new point.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberAdd(Point3d, Vector3f)
Sums up a point and a vector, and returns a new point.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberAdd(Vector3d, Point3d)
Sums up a point and a vector, and returns a new point.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberArePointsCoplanar
Determines whether a set of points is coplanar within a given tolerance.
Public methodCompareTo
Compares this Point3d with another Point3d.

Component evaluation priority is first X, then Y, then Z.

Public methodStatic memberCullDuplicates
Removes duplicates in the supplied set of points.
Public methodCode exampleDistanceTo
Computes the distance between two points.
Public methodDistanceToSquared
Computes the square of the distance between two points.

This method is usually largely faster than DistanceTo().

Public methodStatic memberDivide
Divides a Point3d by a number.

(Provided for languages that do not support operator overloading. You can use the / operator otherwise)

Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified Object is a Point3d and has the same values as the present point.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Point3d)
Determines whether the specified Point3d has the same values as the present point.
Public methodStatic memberFromPoint3f
Converts a single-precision point in a double-precision point.
Public methodGetHashCode
Computes a hash code for the present point.
(Overrides ValueTypeGetHashCode.)
Public methodInterpolate
Interpolate between two points.
Public methodStatic memberMultiply(Double, Point3d)
Multiplies a Point3d by a number.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberMultiply(Point3d, Double)
Multiplies a Point3d by a number.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberSortAndCullPointList
Orders a set of points so they will be connected in a "reasonable polyline" order.

Also, removes points from the list if their common distance exceeds a specified threshold.

Public methodStatic memberSubtract(Point3d, Point3d)
Subtracts a point from another point.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodStatic memberSubtract(Point3d, Vector3d)
Subtracts a vector from a point.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodToString
Constructs the string representation for the current point.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodCode exampleTransform
Transforms the present point in place. The transformation matrix acts on the left of the point. i.e.,

result = transformation*point

Public methodStatic memberTryParse
Converts the string representation of a point to the equivalent Point3d structure.
Top
See Also