Click or drag to resize

CommonObject Properties

The CommonObject type exposes the following members.

Properties
  NameDescription
Public propertyDisposed
Indicates if this object has been disposed or the document it originally belonged to has been disposed.
Public propertyHasUserData
Gets true if this class has any custom information attached to it through UserData.
Public propertyIsDocumentControlled
If true this object may not be modified. Any properties or functions that attempt to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
Public propertyIsValid
Tests an object to see if it is valid.
Public propertyStatic memberPerformCorruptionTesting
Used to test ON_Object* pointers to see if they are a brep or mesh that is corrupt enough to crash Rhino.
Public propertyUserData
List of custom information that is attached to this class.
Public propertyUserDictionary
Dictionary of custom information attached to this class. The dictionary is actually user data provided as an easy to use shareable set of information.
Top
See Also