BrepRegionFaceSide Class |
Namespace: Rhino.Geometry
The BrepRegionFaceSide type exposes the following members.
Name | Description | |
---|---|---|
Brep |
The brep this side belongs to.
IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
Region |
The region this side belongs to.
| |
SurfaceNormalPointsIntoRegion |
Gets true if BrepFace's surface normal points into region; false otherwise.
UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
Name | Description | |
---|---|---|
EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this