SurfaceTryGetTorus Method (Torus, Double) |
Tests a surface to see if it is a portion of a torus and returns the torus.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool TryGetTorus(
out Torus torus,
double tolerance
)
Public Function TryGetTorus (
<OutAttribute> ByRef torus As Torus,
tolerance As Double
) As Boolean
Parameters
- torus
- Type: Rhino.GeometryTorus
On success, the torus parameters are filled in. - tolerance
- Type: SystemDouble
tolerance to use when checking.
Return Value
Type:
Booleantrue if the surface is a portion of a torus.
See Also