Click or drag to resize

SurfaceCreateRollingBallFillet Method (Surface, Surface, Double, Double)

Constructs a rolling ball fillet between two surfaces.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static Surface[] CreateRollingBallFillet(
	Surface surfaceA,
	Surface surfaceB,
	double radius,
	double tolerance
)

Parameters

surfaceA
Type: Rhino.GeometrySurface
A first surface.
surfaceB
Type: Rhino.GeometrySurface
A second surface.
radius
Type: SystemDouble
A radius value.
tolerance
Type: SystemDouble
A tolerance value.

Return Value

Type: Surface
A new array of rolling ball fillet surfaces; this array can be empty on failure.
Exceptions
ExceptionCondition
ArgumentNullExceptionIf surfaceA or surfaceB are null.
See Also