Click or drag to resize

SurfaceVariableOffset Method (Double, Double, Double, Double, Double)

Copies a surface so that all locations at the corners of the copied surface are specified distances from the original surface.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.13
Syntax
public Surface VariableOffset(
	double uMinvMin,
	double uMinvMax,
	double uMaxvMin,
	double uMaxvMax,
	double tolerance
)

Parameters

uMinvMin
Type: SystemDouble
Offset distance at Domain(0).Min, Domain(1).Min.
uMinvMax
Type: SystemDouble
Offset distance at Domain(0).Min, Domain(1).Max.
uMaxvMin
Type: SystemDouble
Offset distance at Domain(0).Max, Domain(1).Min.
uMaxvMax
Type: SystemDouble
Offset distance at Domain(0).Max, Domain(1).Max.
tolerance
Type: SystemDouble
The offset tolerance.

Return Value

Type: Surface
The offset surface if successful, null otherwise.
See Also