Click or drag to resize

SurfaceToNurbsSurface Method (Double, Int32)

Gets a NURBS surface representation of this surface.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public NurbsSurface ToNurbsSurface(
	double tolerance,
	out int accuracy
)

Parameters

tolerance
Type: SystemDouble
tolerance to use when creating NURBS representation.
accuracy
Type: SystemInt32

0 = unable to create NURBS representation with desired accuracy.

1 = success - returned NURBS parameterization matches the surface's to the desired accuracy.

2 = success - returned NURBS point locus matches the surface's to the desired accuracy and the domain of the NURBS surface is correct. However, this surface's parameterization and the NURBS surface parameterization may not match to the desired accuracy. This situation happens when getting NURBS representations of surfaces that have a transcendental parameterization like spheres, cylinders, and cones.

Return Value

Type: NurbsSurface
NurbsSurface on success, null on failure.
See Also