Click or drag to resize

SurfaceRebuild Method

Rebuilds an existing surface to a given degree and point count.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public NurbsSurface Rebuild(
	int uDegree,
	int vDegree,
	int uPointCount,
	int vPointCount
)

Parameters

uDegree
Type: SystemInt32
the output surface u degree.
vDegree
Type: SystemInt32
the output surface u degree.
uPointCount
Type: SystemInt32
The number of points in the output surface u direction. Must be bigger than uDegree (maximum value is 1000)
vPointCount
Type: SystemInt32
The number of points in the output surface v direction. Must be bigger than vDegree (maximum value is 1000)

Return Value

Type: NurbsSurface
new rebuilt surface on success. null on failure.
See Also