Click or drag to resize

SurfaceSplit Method

Splits (divides) the surface into two parts at the specified parameter

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Surface[] Split(
	int direction,
	double parameter
)

Parameters

direction
Type: SystemInt32
0 = The surface is split vertically. The "west" side is returned as the first surface in the array and the "east" side is returned as the second surface in the array. 1 = The surface is split horizontally. The "south" side is returned as the first surface in the array and the "north" side is returned as the second surface in the array
parameter
Type: SystemDouble
value of constant parameter in interval returned by Domain(direction)

Return Value

Type: Surface
Array of two surfaces on success
See Also