RhinoCommon API
RhinoCommon API
Namespaces
Rhino.Geometry
Surface Class
Surface Methods
ClosestPoint Method
ClosestSide Method
CreateExtrusion Method
CreateExtrusionToPoint Method
CreatePeriodicSurface Method
CreateRollingBallFillet Method
CreateSoftEditSurface Method
CurvatureAt Method
Degree Method
Domain Method
Evaluate Method
Extend Method
Fit Method
FitCurveToSurface Method
FrameAt Method
GetNextDiscontinuity Method
GetNurbsFormParameterFromSurfaceParameter Method
GetSpanVector Method
GetSurfaceParameterFromNurbsFormParameter Method
GetSurfaceSize Method
HasNurbsForm Method
InterpolatedCurveOnSurface Method
InterpolatedCurveOnSurfaceUV Method
IsAtSeam Method
IsAtSingularity Method
IsClosed Method
IsCone Method
IsContinuous Method
IsCylinder Method
IsIsoparametric Method
IsoCurve Method
IsPeriodic Method
IsPlanar Method
IsSingular Method
IsSphere Method
IsTorus Method
LocalClosestPoint Method
NormalAt Method
Offset Method
PointAt Method
Pullback Method
Pushup Method
Rebuild Method
RebuildOneDirection Method
RefitSimplySplitSurface Method
RefitSplit Method
Reverse Method
SetDomain Method
ShortPath Method
Smooth Method
SpanCount Method
Split Method
ToBrep Method
ToNurbsSurface Method
Transpose Method
Trim Method
TryGetCone Method
TryGetCylinder Method
TryGetFiniteCylinder Method
TryGetPlane Method
TryGetSphere Method
TryGetTorus Method
VariableOffset Method
Surface
ToBrep Method
Converts the surface into a Brep.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since:
5.0
Syntax
C#
VB
Copy
public
Brep
ToBrep
()
Public
Function
ToBrep
As
Brep
Return Value
Type:
Brep
A Brep with a similar shape like this surface or null.
See Also
Reference
Surface Class
Rhino.Geometry Namespace
Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com