Click or drag to resize

Brep Class

/// Boundary Representation. A surface or polysurface along with trim curve information.
Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class Brep : GeometryBase

The Brep type exposes the following members.

Constructors
  NameDescription
Public methodBrep
Initializes a new empty brep
Protected methodBrep(SerializationInfo, StreamingContext)
Protected constructor used in serialization.
Top
Properties
  NameDescription
Public propertyCurves2D
Parameter space trimming curves (used by trims)
Public propertyCurves3D
Pointers to 3d curves (used by edges)
Public propertyEdges
Gets the brep edges list accessor.
Public propertyFaces
Gets the brep faces list accessor.
Public propertyHasRegionTopology
Returns true if the Brep has region topology information, false otherwise.
Public propertyIsManifold
Gets a value indicating whether or not the Brep is manifold. Non-Manifold breps have at least one edge that is shared among three or more faces.
Public propertyCode exampleIsSolid
Determines whether this brep is a solid, or a closed oriented manifold.
Public propertyIsSurface
Returns true if the Brep has a single face and that face is geometrically the same as the underlying surface. I.e., the face has trivial trimming.

In this case, the surface is the first face surface. The flag Brep.Faces[0].OrientationIsReversed records the correspondence between the surface's natural parametric orientation and the orientation of the Brep.

trivial trimming here means that there is only one loop curve in the brep and that loop curve is the same as the underlying surface boundary.

Public propertyLoops
Gets the brep loop list accessor.
Public propertySolidOrientation
Gets the solid orientation state of this Brep.
Public propertySurfaces
Parametric surfaces used by faces
Public propertyTrims
Gets the brep trims list accessor.
Public propertyVertices
Gets the brep vertices list accessor.
Top
Methods
  NameDescription
Public methodAddEdgeCurve
Add a 3d curve used by the brep edges
Public methodAddSurface
Adds a 3D surface used by BrepFace.
Public methodAddTrimCurve
Add a 2d curve used by the brep trims
Public methodAppend
Appends a copy of another brep to this and updates indices of appended brep parts. Duplicates are not removed
Public methodCapPlanarHoles
Returns a new Brep that is equivalent to this Brep with all planar holes capped.
Public methodStatic memberChangeSeam
Change the seam of a closed trimmed surface.
Public methodClosestPoint(Point3d)
Finds a point on the brep that is closest to testPoint.
Public methodClosestPoint(Point3d, Point3d, ComponentIndex, Double, Double, Double, Vector3d)
Finds a point on the Brep that is closest to testPoint. The method searches all Brep faces looking for the one closest to testPoint. When found, if the closest point falls on the inactive region of the face, then the method finds the face's edge that is closest to testPoint.
Public methodCompact
Deletes any unreferenced objects from arrays, re-indexes as needed, and shrinks arrays to minimum required size. Uses CUllUnused* members to delete any unreferenced objects from arrays.
Public methodStatic memberCopyTrimCurves
Copy all trims from a Brep face onto a surface.
Public methodStatic memberCreateBaseballSphere
Creates a brep representation of the sphere with two similar trimmed NURBS surfaces, and no singularities.
Public methodStatic memberCreateBlendShape
Makes a curve blend between points on two surface edges. The blend will be tangent to the surfaces and perpendicular to the edges.
Public methodStatic memberCreateBlendSurface
Makes a surface blend between two surface edges.
Public methodStatic memberCreateBooleanDifference(Brep, Brep, Double)
Compute the Solid Difference of two Breps.
Public methodStatic memberCode exampleCreateBooleanDifference(IEnumerableBrep, IEnumerableBrep, Double)
Compute the Solid Difference of two sets of Breps.
Public methodStatic memberCreateBooleanDifference(Brep, Brep, Double, Boolean)
Compute the Solid Difference of two Breps.
Public methodStatic memberCode exampleCreateBooleanDifference(IEnumerableBrep, IEnumerableBrep, Double, Boolean)
Compute the Solid Difference of two sets of Breps.
Public methodStatic memberCreateBooleanIntersection(Brep, Brep, Double)
Compute the Solid Intersection of two Breps.
Public methodStatic memberCreateBooleanIntersection(IEnumerableBrep, IEnumerableBrep, Double)
Compute the Solid Intersection of two sets of Breps.
Public methodStatic memberCreateBooleanIntersection(Brep, Brep, Double, Boolean)
Compute the Solid Intersection of two Breps.
Public methodStatic memberCreateBooleanIntersection(IEnumerableBrep, IEnumerableBrep, Double, Boolean)
Compute the Solid Intersection of two sets of Breps.
Public methodStatic memberCreateBooleanSplit(Brep, Brep, Double)
Splits shared areas of Breps and creates separate Breps from the shared and unshared parts.
Public methodStatic memberCreateBooleanSplit(IEnumerableBrep, IEnumerableBrep, Double)
Splits shared areas of Breps and creates separate Breps from the shared and unshared parts.
Public methodStatic memberCreateBooleanUnion(IEnumerableBrep, Double)
Compute the Boolean Union of a set of Breps.
Public methodStatic memberCreateBooleanUnion(IEnumerableBrep, Double, Boolean)
Compute the Boolean Union of a set of Breps.
Public methodStatic memberCreateBooleanUnion(IEnumerableBrep, Double, Boolean, Point3d, Point3d, Point3d)
Compute the Boolean Union of a set of Breps.
Public methodStatic memberCreateChamferSurface(BrepFace, Point2d, Double, BrepFace, Point2d, Double, Boolean, Double)
Creates a ruled surface as a bevel between two input surface edges.
Public methodStatic memberCreateChamferSurface(BrepFace, Point2d, Double, BrepFace, Point2d, Double, Boolean, Boolean, Double, Brep, Brep)
Creates a ruled surface as a bevel between two input surface edges.
Public methodStatic memberCreateContourCurves(Brep, Plane)
Constructs the contour curves for a brep, using a slicing plane.
Public methodStatic memberCode exampleCreateContourCurves(Brep, Point3d, Point3d, Double)
Constructs the contour curves for a brep at a specified interval.
Public methodStatic memberCreateCurvatureAnalysisMesh
Create an array of analysis meshes for the brep using the specified settings. Meshes aren't set on the brep.
Public methodStatic memberCreateDevelopableLoft(NurbsCurve, NurbsCurve, IEnumerablePoint2d)
Creates a single developable surface between two curves.
Public methodStatic memberCreateDevelopableLoft(Curve, Curve, Boolean, Boolean, Int32)
Creates a single developable surface between two curves.
Public methodStatic memberCode exampleCreateEdgeSurface
Constructs a coons patch from 2, 3, or 4 curves.
Public methodStatic memberCreateFilletEdges(Brep, IEnumerableInt32, IEnumerableDouble, IEnumerableDouble, BlendType, RailType, Double)
Fillets, chamfers, or blends the edges of a brep.
Public methodStatic memberCreateFilletEdges(Brep, IEnumerableInt32, IEnumerableDouble, IEnumerableDouble, BlendType, RailType, Boolean, Double, Double)
Fillets, chamfers, or blends the edges of a brep.
Public methodStatic memberCreateFilletEdgesVariableRadius
Fillets, chamfers, or blends the edges of a brep.
Public methodStatic memberCreateFilletSurface(BrepFace, Point2d, BrepFace, Point2d, Double, Boolean, Double)
Creates a constant-radius round surface between two surfaces.
Public methodStatic memberCreateFilletSurface(BrepFace, Point2d, BrepFace, Point2d, Double, Boolean, Boolean, Double, Brep, Brep)
Creates a constant-radius round surface between two surfaces.
Public methodStatic memberCode exampleCreateFromBox(BoundingBox)
Constructs new brep that matches a bounding box.
Public methodStatic memberCreateFromBox(Box)
Constructs new brep that matches an aligned box.
Public methodStatic memberCreateFromBox(IEnumerablePoint3d)
Constructs new brep from 8 corner points.
Public methodStatic memberCreateFromCone
Constructs a Brep representation of the cone with a single face for the cone, an edge along the cone seam, and vertices at the base and apex ends of this seam edge. The optional cap is a single face with one circular edge starting and ending at the base vertex.
Public methodStatic memberCreateFromCornerPoints(Point3d, Point3d, Point3d, Double)
Makes a Brep with one face from three corner points.
Public methodStatic memberCreateFromCornerPoints(Point3d, Point3d, Point3d, Point3d, Double)
Makes a Brep with one face from four corner points.
Public methodStatic memberCreateFromCylinder
Constructs a Brep definition of a cylinder.
Public methodStatic memberCreateFromJoinedEdges
Joins two naked edges, or edges that are coincident or close together, from two Breps.
Public methodStatic memberCode exampleCreateFromLoft(IEnumerableCurve, Point3d, Point3d, LoftType, Boolean)
Constructs one or more Breps by lofting through a set of curves.
Public methodStatic memberCreateFromLoft(IEnumerableCurve, Point3d, Point3d, Boolean, Boolean, BrepTrim, BrepTrim, LoftType, Boolean)
Constructs one or more Breps by lofting through a set of curves, optionally matching start and end tangents of surfaces when first and/or last loft curves are surface edges
Public methodStatic memberCreateFromLoftRebuild
Constructs one or more Breps by lofting through a set of curves. Input for the loft is simplified by rebuilding to a specified number of control points.
Public methodStatic memberCreateFromLoftRefit
Constructs one or more Breps by lofting through a set of curves. Input for the loft is simplified by refitting to a specified tolerance.
Public methodStatic memberCreateFromMesh
Create a brep representation of a mesh
Public methodStatic memberCreateFromOffsetFace
Offsets a face including trim information to create a new brep.
Public methodStatic memberCode exampleCreateFromRevSurface
Constructs a brep form of a surface of revolution.
Public methodStatic memberCreateFromSphere
Constructs a Brep definition of a sphere.
Public methodStatic memberCreateFromSurface
Constructs a Brep from a surface. The resulting Brep has an outer boundary made from four trims. The trims are ordered so that they run along the south, east, north, and then west side of the surface's parameter space.
Public methodStatic memberCreateFromSweep(Curve, Curve, Boolean, Double)
Sweep1 function that fits a surface through a profile curve that define the surface cross-sections and one curve that defines a surface edge.
Public methodStatic memberCreateFromSweep(Curve, IEnumerableCurve, Boolean, Double)
Sweep1 function that fits a surface through profile curves that define the surface cross-sections and one curve that defines a surface edge.
Public methodStatic memberCreateFromSweep(Curve, Curve, Curve, Boolean, Double)
General 2 rail sweep. If you are not producing the sweep results that you are after, then use the SweepTwoRail class with options to generate the swept geometry.
Public methodStatic memberCreateFromSweep(Curve, Curve, IEnumerableCurve, Boolean, Double)
General 2 rail sweep. If you are not producing the sweep results that you are after, then use the SweepTwoRail class with options to generate the swept geometry.
Public methodStatic memberCreateFromSweep(Curve, Curve, IEnumerableCurve, Point3d, Point3d, Boolean, Double, SweepRebuild, Int32, Double, Boolean)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines the surface edges.
Public methodStatic memberCreateFromSweep(Curve, Curve, IEnumerableCurve, Point3d, Point3d, Boolean, Double, SweepRebuild, Int32, Double, Boolean, Boolean)
Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines the surface edges.
Public methodStatic memberCreateFromSweep(Curve, IEnumerableCurve, Point3d, Point3d, SweepFrame, Vector3d, Boolean, SweepBlend, SweepMiter, Double, SweepRebuild, Int32, Double)
Sweep1 function that fits a surface through a series of profile curves that define the surface cross-sections and one curve that defines a surface edge.
Public methodStatic memberCreateFromSweepInParts
Makes a 2 rail sweep. Like CreateFromSweep but the result is split where parameterization along a rail changes abruptly.
Public methodStatic memberCreateFromSweepSegmented(Curve, Curve, Boolean, Double)
Sweep1 function that fits a surface through a profile curve that define the surface cross-sections and one curve that defines a surface edge. The Segmented version breaks the rail at curvature kinks and sweeps each piece separately, then put the results together into a Brep.
Public methodStatic memberCreateFromSweepSegmented(Curve, IEnumerableCurve, Boolean, Double)
Sweep1 function that fits a surface through a series of profile curves that define the surface cross-sections and one curve that defines a surface edge. The Segmented version breaks the rail at curvature kinks and sweeps each piece separately, then put the results together into a Brep.
Public methodStatic memberCreateFromSweepSegmented(Curve, IEnumerableCurve, Point3d, Point3d, SweepFrame, Vector3d, Boolean, SweepBlend, SweepMiter, Double, SweepRebuild, Int32, Double)
Sweep1 function that fits a surface through a series of profile curves that define the surface cross-sections and one curve that defines a surface edge. The Segmented version breaks the rail at curvature kinks and sweeps each piece separately, then put the results together into a Brep.
Public methodStatic memberCreateFromTaperedExtrude(Curve, Double, Vector3d, Point3d, Double, ExtrudeCornerType) Obsolete.
Extrude a curve to a taper making a brep (potentially more than 1)
Public methodStatic memberCreateFromTaperedExtrude(Curve, Double, Vector3d, Point3d, Double, ExtrudeCornerType, Double, Double)
Extrude a curve to a taper making a brep (potentially more than 1)
Public methodStatic memberCreateFromTaperedExtrudeWithRef
Creates one or more Breps by extruding a curve a distance along an axis with draft angle.
Public methodStatic memberCreateFromTorus
Constructs a Brep definition of a torus.
Public methodStatic memberCreateOffsetBrep(Brep, Double, Boolean, Boolean, Double, Brep, Brep)
Offsets a Brep.
Public methodStatic memberCreateOffsetBrep(Brep, Double, Boolean, Boolean, Boolean, Double, Brep, Brep)
Offsets a Brep.
Public methodStatic memberCreatePatch(IEnumerableGeometryBase, Surface, Double)
Constructs a brep patch.

This is the simple version of fit that uses a specified starting surface.

Public methodStatic memberCreatePatch(IEnumerableGeometryBase, Int32, Int32, Double)
Constructs a brep patch.

This is the simple version of fit that uses a plane with u x v spans. It makes a plane by fitting to the points from the input geometry to use as the starting surface. The surface has the specified u and v span count.

Public methodStatic memberCreatePatch(IEnumerableGeometryBase, Surface, Int32, Int32, Boolean, Boolean, Double, Double, Double, Boolean, Double)
Constructs a brep patch using all controls
Public methodStatic memberCreatePipe(Curve, Double, Boolean, PipeCapMode, Boolean, Double, Double)
Creates a single walled pipe.
Public methodStatic memberCreatePipe(Curve, IEnumerableDouble, IEnumerableDouble, Boolean, PipeCapMode, Boolean, Double, Double)
Creates a single walled pipe.
Public methodStatic memberCreatePlanarBreps(Curve) Obsolete.
Constructs a set of planar breps as outlines by the loops.
Public methodStatic memberCreatePlanarBreps(CurveList) Obsolete.
Constructs a set of planar Breps as outlines by the loops.
Public methodStatic memberCreatePlanarBreps(IEnumerableCurve) Obsolete.
Constructs a set of planar breps as outlines by the loops.
Public methodStatic memberCreatePlanarBreps(Curve, Double)
Constructs a set of planar breps as outlines by the loops.
Public methodStatic memberCreatePlanarBreps(CurveList, Double)
Constructs a set of planar Breps as outlines by the loops.
Public methodStatic memberCreatePlanarBreps(IEnumerableCurve, Double)
Constructs a set of planar breps as outlines by the loops.
Public methodStatic memberCreatePlanarDifference
CreatePlanarDifference
Public methodStatic memberCreatePlanarIntersection
CreatePlanarIntersection
Public methodStatic memberCreatePlanarUnion(IEnumerableBrep, Plane, Double)
CreatePlanarUnion
Public methodStatic memberCreatePlanarUnion(Brep, Brep, Plane, Double)
CreatePlanarUnion
Public methodStatic memberCreateQuadSphere
Constructs a Brep definition of a quad sphere.
Public methodStatic memberCreateShell
Creates a hollowed out shell from a solid Brep. Function only operates on simple, solid, manifold Breps.
Public methodStatic memberCreateSolid
Constructs closed polysurfaces from surfaces and polysurfaces that bound a region in space.
Public methodStatic memberCreateThickPipe(Curve, Double, Double, Boolean, PipeCapMode, Boolean, Double, Double)
Creates a double-walled pipe.
Public methodStatic memberCreateThickPipe(Curve, IEnumerableDouble, IEnumerableDouble, IEnumerableDouble, Boolean, PipeCapMode, Boolean, Double, Double)
Creates a double-walled pipe.
Public methodStatic memberCreateTrimmedPlane(Plane, Curve)
Create a Brep trimmed plane.
Public methodStatic memberCreateTrimmedPlane(Plane, IEnumerableCurve)
Create a Brep trimmed plane.
Public methodStatic memberCreateTrimmedSurface(BrepFace, Surface) Obsolete.
Constructs a Brep using the trimming information of a brep face and a surface. Surface must be roughly the same shape and in the same location as the trimming brep face.
Public methodStatic memberCreateTrimmedSurface(BrepFace, Surface, Double)
Constructs a Brep using the trimming information of a brep face and a surface. Surface must be roughly the same shape and in the same location as the trimming brep face.
Public methodCullUnused2dCurves
Culls 3d curves not referenced by an edge.
Public methodCullUnused3dCurves
Culls 2d curves not referenced by a trim.
Public methodCullUnusedEdges
Culls edges with m_edge_index == -1.
Public methodCullUnusedFaces
Culls faces with m_face_index == -1.
Public methodCullUnusedLoops
Culls loops with m_loop_index == -1.
Public methodCullUnusedSurfaces
Culls surfaces not referenced by a face.
Public methodCullUnusedTrims
Culls trims with m_trim_index == -1.
Public methodCullUnusedVertices
Culls vertices with m_vertex_index == -1.
Public methodStatic memberCutUpSurface
Takes a surface and a set of all 3D curves that define a single trimmed surface, and splits the surface with the curves, keeping the piece that uses all of the curves.
Public methodDestroyRegionTopology
Destroys a Brep's region topology information.
Public methodDuplicate
Copies this brep.
(Overrides GeometryBaseDuplicate.)
Public methodDuplicateBrep
Same as Duplicate, but already performs a cast to a brep.

This cast always succeeds.

Public methodDuplicateEdgeCurves
Duplicate all the edges of this Brep.
Public methodCode exampleDuplicateEdgeCurves(Boolean)
Duplicate edges of this Brep.
Public methodDuplicateNakedEdgeCurves
Duplicate naked edges of this Brep.
Public methodDuplicateSubBrep
Copy a subset of this Brep into another Brep.
Public methodDuplicateVertices
Duplicate all the corner vertices of this Brep.
Public methodStatic memberExtendBrepFacesToConnect(BrepFace, Point3d, BrepFace, Point3d, Double, Double, Brep, Brep)
Extends Faces to meet and trims the faces to each other. If input faces intersect without extending, the selection point indicates the side to keep
Public methodStatic memberExtendBrepFacesToConnect(BrepFace, Int32, BrepFace, Int32, Double, Double, Brep, Brep)
Extends Faces to meet and trims the faces to each other. If input faces intersect without extending, the selection point indicates the side to keep
Public methodFindCoincidentBrepComponents
Find the indices of all brep faces, edges and vertices that are within tolerance of a test-point.
Public methodFlip
Reverses entire brep orientation of all faces.
Public methodGetArea
Compute the Area of the Brep. If you want proper Area data with moments and error information, use the AreaMassProperties class.
Public methodGetArea(Double, Double)
Compute the Area of the Brep. If you want proper Area data with moments and error information, use the AreaMassProperties class.
Public methodGetConnectedComponents
If this Brep has two or more connected components, then duplicates of the connected components are returned.
Public methodGetPointInside
Finds a point inside of a solid Brep.
Public methodGetRegions
Gets an array containing all regions in this brep.
Public methodGetTangentConnectedComponents
If this Brep has two or more components connected by tangent edges, then duplicates of the connected components are returned.
Public methodGetVolume
Compute the Volume of the Brep. If you want proper Volume data with moments and error information, use the VolumeMassProperties class.
Public methodGetVolume(Double, Double)
Compute the Volume of the Brep. If you want proper Volume data with moments and error information, use the VolumeMassProperties class.
Public methodGetWireframe
Constructs all the Wireframe curves for this Brep.
Public methodInsetFaces
Individually insets faces of a brep by offsetting the faces outer edges inward and inner edges out then splitting the face with the offset curves.
Public methodIsBox
Verifies a Brep is in the form of a solid box.
Public methodIsBox(Double)
Verifies a Brep is in the form of a solid box.
Public methodIsDuplicate
See if this and other are same brep geometry.
Public methodIsPointInside
Determines if point is inside a Brep. This question only makes sense when the brep is a closed and manifold. This function does not check for closed or manifold, so result is not valid in those cases. Intersects a line through point with brep, finds the intersection point Q closest to point, and looks at face normal at Q. If the point Q is on an edge or the intersection is not transverse at Q, then another line is used.
Public methodIsValidGeometry
Expert user function that tests the brep to see if its geometry information is valid. The value of brep.IsValidTopology() must be true before brep.IsValidGeometry() can be safely called.
Public methodIsValidTolerancesAndFlags
Expert user function that tests the brep to see if its tolerances and flags are valid. The values of brep.IsValidTopology() and brep.IsValidGeometry() must be true before brep.IsValidTolerancesAndFlags() can be safely called.
Public methodIsValidTopology
Tests the brep to see if its topology information is valid.
Public methodJoin
If any edges of this brep overlap edges of otherBrep, merge a copy of otherBrep into this brep joining all edges that overlap within tolerance.
Public methodStatic memberJoinBreps(IEnumerableBrep, Double)
Joins the breps in the input array at any overlapping edges to form as few as possible resulting breps. There may be more than one brep in the result array.
Public methodStatic memberJoinBreps(IEnumerableBrep, Double, Double)
Joins the breps in the input array at any overlapping edges to form as few as possible resulting breps. There may be more than one brep in the result array.
Public methodStatic memberJoinBreps(IEnumerableBrep, Double, Double, ListInt32)
Joins the breps in the input array at any overlapping edges to form as few as possible resulting breps. There may be more than one brep in the result array.
Public methodJoinEdges
Joins two naked edges, or edges that are coincident or close together.
Public methodJoinNakedEdges
Joins naked edge pairs within the same brep that overlap within tolerance.
Public methodMakeValidForV2
No support is available for this function.

Expert user function that converts all geometry in Brep to NURB form.

Public methodStatic memberMergeBreps
Combines two or more breps into one. A merge is like a boolean union that keeps the inside pieces. This function creates non-manifold Breps which in general are unusual in Rhino. You may want to consider using JoinBreps or CreateBooleanUnion functions instead.
Public methodMergeCoplanarFaces(Double)
Merges adjacent coplanar faces into single faces.
Public methodMergeCoplanarFaces(Double, Double)
Merges adjacent coplanar faces into single faces.
Public methodMergeCoplanarFaces(Int32, Double, Double)
Merges coplanar faces adjacent to Brep face into a single face.
Public methodMergeCoplanarFaces(Int32, Int32, Double, Double)
Merges two coplanar, adjacent Brep faces into a single face.
Public methodStatic memberMergeSurfaces(Brep, Brep, Double, Double)
Merges two surfaces into one surface at untrimmed edges. Both surfaces must be untrimmed and share an edge.
Public methodStatic memberMergeSurfaces(Surface, Surface, Double, Double)
Merges two surfaces into one surface at untrimmed edges.
Public methodStatic memberMergeSurfaces(Brep, Brep, Double, Double, Point2d, Point2d, Double, Boolean)
Merges two surfaces into one surface at untrimmed edges. Both surfaces must be untrimmed and share an edge.
Public methodRebuildTrimsForV2
No support is available for this function.

Expert user function used by MakeValidForV2 to convert trim curves from one surface to its NURBS form. After calling this function, you need to change the surface of the face to a NurbsSurface.

Public methodRemoveFins
Recursively removes any Brep face with a naked edge. This function is only useful for non-manifold Breps.
Public methodRemoveHoles(Double)
Remove all inner loops, or holes, in a Brep.
Public methodRemoveHoles(IEnumerableComponentIndex, Double)
Removes inner loops, or holes, in a Brep.
Public methodRepair
Fills in missing or fixes incorrect component information from a Brep. Useful when reading Brep information from other file formats that do not provide as complete of a Brep definition as required by Rhino.
Public methodSetTolerancesBoxesAndFlags
Set tolerances and flags in a Brep.
Public methodSetTolerancesBoxesAndFlags(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Set tolerances and flags in a Brep.
Public methodSetTrimIsoFlags
This function can be used to set the BrepTrim::m_iso flag. It is intended to be used when creating a Brep from a definition that does not include compatible parameter space type information.
Public methodSetVertices
This function can be used to compute vertex information for a b-rep when everything but the Vertices array is properly filled in. It is intended to be used when creating a Brep from a definition that does not include explicit vertex information.
Public methodSplit(Brep, Double)
Splits a Brep into pieces using a Brep as a cutter.
Public methodSplit(IEnumerableBrep, Double)
Splits a Brep into pieces using Breps as cutters.
Public methodSplit(IEnumerableCurve, Double)
Splits a Brep into pieces using curves, at least partially on the Brep, as cutters.
Public methodSplit(Brep, Double, Boolean)
Splits a Brep into pieces using a Brep as a cutter.
Public methodSplit(IEnumerableGeometryBase, Vector3d, Boolean, Double)
Splits a Brep into pieces using a combination of curves, to be extruded, and Breps as cutters.
Public methodStandardize
Standardizes all trims, edges, and faces in the brep. After standardizing, there may be unused curves and surfaces in the brep. Call Brep.Compact to remove these unused curves and surfaces.
Public methodTransformComponent
Transform an array of Brep components, bend neighbors to match, and leave the rest fixed.
Public methodTrim(Brep, Double)
Trims a brep with an oriented cutter. The parts of the brep that lie inside (opposite the normal) of the cutter are retained while the parts to the outside (in the direction of the normal) are discarded. If the Cutter is closed, then a connected component of the Brep that does not intersect the cutter is kept if and only if it is contained in the inside of cutter. That is the region bounded by cutter opposite from the normal of cutter, If cutter is not closed all these components are kept.
Public methodTrim(Plane, Double)
Trims a Brep with an oriented cutter. The parts of Brep that lie inside (opposite the normal) of the cutter are retained while the parts to the outside ( in the direction of the normal ) are discarded. A connected component of Brep that does not intersect the cutter is kept if and only if it is contained in the inside of Cutter. That is the region bounded by cutter opposite from the normal of cutter, or in the case of a Plane cutter the half space opposite from the plane normal.
Public methodStatic memberTryConvertBrep
Attempts to convert a generic Geometry object into a Brep.
Public methodUnjoinEdges
Un-joins, or separates, edges within the Brep. Note, seams in closed surfaces will not separate.
Top
See Also