Click or drag to resize

BrepCreateBooleanIntersection Method (IEnumerableBrep, IEnumerableBrep, Double, Boolean)

Compute the Solid Intersection of two sets of Breps.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static Brep[] CreateBooleanIntersection(
	IEnumerable<Brep> firstSet,
	IEnumerable<Brep> secondSet,
	double tolerance,
	bool manifoldOnly
)

Parameters

firstSet
Type: System.Collections.GenericIEnumerableBrep
First set of Breps.
secondSet
Type: System.Collections.GenericIEnumerableBrep
Second set of Breps.
tolerance
Type: SystemDouble
Tolerance to use for intersection operation.
manifoldOnly
Type: SystemBoolean
If true, non-manifold input breps are ignored.

Return Value

Type: Brep
An array of Brep results or null on failure.
Remarks
The solid orientation of the breps make a difference when calling this function
See Also