Click or drag to resize

BrepCreateBooleanIntersection Method (Brep, Brep, Double, Boolean)

Compute the Solid Intersection of two Breps.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static Brep[] CreateBooleanIntersection(
	Brep firstBrep,
	Brep secondBrep,
	double tolerance,
	bool manifoldOnly
)

Parameters

firstBrep
Type: Rhino.GeometryBrep
First Brep for boolean intersection.
secondBrep
Type: Rhino.GeometryBrep
Second Brep for boolean intersection.
tolerance
Type: SystemDouble
Tolerance to use for intersection operation.
manifoldOnly
Type: SystemBoolean
If true, non-manifold input breps are ignored.

Return Value

Type: Brep
An array of Brep results or null on failure.
Remarks
The solid orientation of the breps make a difference when calling this function
See Also