Click or drag to resize

BrepExtendBrepFacesToConnect Method (BrepFace, Point3d, BrepFace, Point3d, Double, Double, Brep, Brep)

Extends Faces to meet and trims the faces to each other. If input faces intersect without extending, the selection point indicates the side to keep

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static bool ExtendBrepFacesToConnect(
	BrepFace Face0,
	Point3d f0_sel_pt,
	BrepFace Face1,
	Point3d f1_sel_pt,
	double tol,
	double angleTol,
	out Brep outBrep0,
	out Brep outBrep1
)

Parameters

Face0
Type: Rhino.GeometryBrepFace
[in] first face to connect
f0_sel_pt
Type: Rhino.GeometryPoint3d
selection point on first face near the edge to extend.
Face1
Type: Rhino.GeometryBrepFace
[in] second surface
f1_sel_pt
Type: Rhino.GeometryPoint3d
selection point on second face near the edge to extend.
tol
Type: SystemDouble
[in] tolerance used for intersecting faces and simplifing extension curve
angleTol
Type: SystemDouble
[in] angle tolerance in radians used for simplifying extendsion curve
outBrep0
Type: Rhino.GeometryBrep
[out] first face extended and trimmed to connect with the second face
outBrep1
Type: Rhino.GeometryBrep
[out] second face extended and trimmed to connect with the first face

Return Value

Type: Boolean
true if valid connection found
See Also