Click or drag to resize

Brep Properties

The Brep type exposes the following members.

Properties
  NameDescription
Public propertyCurves2D
Parameter space trimming curves (used by trims)
Public propertyCurves3D
Pointers to 3d curves (used by edges)
Public propertyEdges
Gets the brep edges list accessor.
Public propertyFaces
Gets the brep faces list accessor.
Public propertyHasRegionTopology
Returns true if the Brep has region topology information, false otherwise.
Public propertyIsManifold
Gets a value indicating whether or not the Brep is manifold. Non-Manifold breps have at least one edge that is shared among three or more faces.
Public propertyCode exampleIsSolid
Determines whether this brep is a solid, or a closed oriented manifold.
Public propertyIsSurface
Returns true if the Brep has a single face and that face is geometrically the same as the underlying surface. I.e., the face has trivial trimming.

In this case, the surface is the first face surface. The flag Brep.Faces[0].OrientationIsReversed records the correspondence between the surface's natural parametric orientation and the orientation of the Brep.

trivial trimming here means that there is only one loop curve in the brep and that loop curve is the same as the underlying surface boundary.

Public propertyLoops
Gets the brep loop list accessor.
Public propertySolidOrientation
Gets the solid orientation state of this Brep.
Public propertySurfaces
Parametric surfaces used by faces
Public propertyTrims
Gets the brep trims list accessor.
Public propertyVertices
Gets the brep vertices list accessor.
Top
See Also