Click or drag to resize

BrepMergeCoplanarFaces Method (Double, Double)

Merges adjacent coplanar faces into single faces.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.10
Syntax
public bool MergeCoplanarFaces(
	double tolerance,
	double angleTolerance
)

Parameters

tolerance
Type: SystemDouble
Tolerance for determining when edges are adjacent. When in doubt, use the document's ModelAbsoluteTolerance property.
angleTolerance
Type: SystemDouble
Angle tolerance, in radians, for determining when faces are parallel. When in doubt, use the document's ModelAngleToleranceRadians property.

Return Value

Type: Boolean
true if faces were merged, false if no faces were merged.
See Also