Click or drag to resize

BrepCreateTrimmedPlane Method (Plane, IEnumerableCurve)

Create a Brep trimmed plane.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static Brep CreateTrimmedPlane(
	Plane plane,
	IEnumerable<Curve> curves
)

Parameters

plane
Type: Rhino.GeometryPlane
Plane that will be trimmed.
curves
Type: System.Collections.GenericIEnumerableCurve
A list of curves that form a simple (no self intersections) closed curve that defines the outer boundary of the trimmed plane.

Return Value

Type: Brep
Resulting brep or null on failure.
See Also