Click or drag to resize

Curve Class

Represents a base class that is common to most RhinoCommon curve types.

A curve represents an entity that can be all visited by providing a single parameter, usually called t.

Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class Curve : GeometryBase

The Curve type exposes the following members.

Constructors
  NameDescription
Protected methodCurve
Protected serialization constructor for internal use.
Top
Properties
  NameDescription
Public propertyDegree
Gets the maximum algebraic degree of any span or a good estimate if curve spans are not algebraic.
Public propertyDimension
Gets the dimension of the object.

The dimension is typically three. For parameter space trimming curves the dimension is two. In rare cases the dimension can be one or greater than three.

Public propertyDomain
Gets or sets the domain of the curve.
Public propertyIsClosed
Gets a value indicating whether or not this curve is a closed curve.
Public propertyIsPeriodic
Gets a value indicating whether or not this curve is considered to be Periodic.
Public propertyIsSubDFriendly
Returns true if the curve is a cubic, non-rational, uniform NURBS curve that is either periodic or has natural end conditions. Otherwise, false is returned.
Public propertyPointAtEnd
Evaluates point at the end of the curve.
Public propertyPointAtStart
Evaluates point at the start of the curve.
Public propertySpanCount
Gets the number of non-empty smooth (c-infinity) spans in the curve.
Public propertyTangentAtEnd
Evaluate unit tangent vector at the end of the curve.
Public propertyTangentAtStart
Evaluates the unit tangent vector at the start of the curve.
Top
Methods
  NameDescription
Public methodChangeClosedCurveSeam
If this curve is closed, then modify it so that the start/end point is at curve parameter t.
Public methodChangeDimension
Changes the dimension of a curve.
Public methodClosedCurveOrientation
Determines the orientation (counterclockwise or clockwise) of a closed, planar curve in the world XY plane. Only works with simple (no self intersections) closed, planar curves.
Public methodClosedCurveOrientation(Plane)
Determines the orientation (counterclockwise or clockwise) of a closed, planar curve in a given plane. Only works with simple (no self intersections) closed, planar curves.
Public methodClosedCurveOrientation(Transform)
Determines the orientation (counterclockwise or clockwise) of a closed, planar curve. Only works with simple (no self intersections) closed, planar curves.
Public methodClosedCurveOrientation(Vector3d)
Determines the orientation (counterclockwise or clockwise) of a closed, planar curve in a given plane. Only works with simple (no self intersections) closed, planar curves.
Public methodClosestPoint(Point3d, Double)
Finds parameter of the point on a curve that is closest to testPoint. If the maximumDistance parameter is > 0, then only points whose distance to the given point is <= maximumDistance will be returned. Using a positive value of maximumDistance can substantially speed up the search.
Public methodClosestPoint(Point3d, Double, Double)
Finds the parameter of the point on a curve that is closest to testPoint. If the maximumDistance parameter is > 0, then only points whose distance to the given point is <= maximumDistance will be returned. Using a positive value of maximumDistance can substantially speed up the search.
Public methodClosestPoints(Curve, Point3d, Point3d)
Gets closest points between this and another curves.
Public methodClosestPoints(IEnumerableGeometryBase, Point3d, Point3d, Int32)
Finds the object (and the closest point in that object) that is closest to this curve.

Breps, surfaces, curves and point clouds are examples of objects that can be passed to this function.

Public methodClosestPoints(IEnumerableGeometryBase, Point3d, Point3d, Int32, Double)
Finds the object (and the closest point in that object) that is closest to this curve.

Breps, surfaces, curves and point clouds are examples of objects that can be passed to this function.

Public methodCombineShortSegments
Looks for segments that are shorter than tolerance that can be combined. For NURBS of degree greater than 1, spans are combined by removing knots. Similarly for NURBS segments of polycurves. Otherwise, RemoveShortSegments() is called. Does not change the domain, but it will change the relative parameterization.
Public methodContains(Point3d) Obsolete.
Computes the relationship between a point and a closed curve region. This curve must be closed or the return value will be Unset. Both curve and point are projected to the World XY plane.
Public methodContains(Point3d, Plane) Obsolete.
Computes the relationship between a point and a closed curve region. This curve must be closed or the return value will be Unset.
Public methodContains(Point3d, Plane, Double)
Computes the relationship between a point and a closed curve region. This curve must be closed or the return value will be Unset.
Public methodStatic memberCreateArcBlend
Creates a polycurve consisting of two tangent arc segments that connect two points and two directions.
Public methodStatic memberCreateArcLineArcBlend
Creates an arc-line-arc blend curve between two curves. The output is generally a PolyCurve with three segments: arc, line, arc. In some cases, one or more of those segments will be absent because they would have 0 length. If there is only a single segment, the result will either be an ArcCurve or a LineCurve.
Public methodStatic memberCreateBlendCurve(Curve, Curve, BlendContinuity)
Create a Blend curve between two existing curves.
Public methodStatic memberCreateBlendCurve(Curve, Curve, BlendContinuity, Double, Double)
Create a Blend curve between two existing curves.
Public methodStatic memberCreateBlendCurve(Curve, Double, Boolean, BlendContinuity, Curve, Double, Boolean, BlendContinuity)
Makes a curve blend between 2 curves at the parameters specified with the directions and continuities specified
Public methodStatic memberCreateBooleanDifference(Curve, Curve) Obsolete.
Calculates the boolean difference between two closed, planar curves. Note, curves must be co-planar.
Public methodStatic memberCreateBooleanDifference(Curve, IEnumerableCurve) Obsolete.
Calculates the boolean difference between a closed planar curve, and a list of closed planar curves. Note, curves must be co-planar.
Public methodStatic memberCreateBooleanDifference(Curve, Curve, Double)
Calculates the boolean difference between two closed, planar curves. Note, curves must be co-planar.
Public methodStatic memberCreateBooleanDifference(Curve, IEnumerableCurve, Double)
Calculates the boolean difference between a closed planar curve, and a list of closed planar curves. Note, curves must be co-planar.
Public methodStatic memberCreateBooleanIntersection(Curve, Curve) Obsolete.
Calculates the boolean intersection of two closed, planar curves. Note, curves must be co-planar.
Public methodStatic memberCreateBooleanIntersection(Curve, Curve, Double)
Calculates the boolean intersection of two closed, planar curves. Note, curves must be co-planar.
Public methodStatic memberCreateBooleanRegions(IEnumerableCurve, Plane, Boolean, Double)
Calculates curve Boolean regions, which trims and splits curves based on their overlapping regions.
Public methodStatic memberCreateBooleanRegions(IEnumerableCurve, Plane, IEnumerablePoint3d, Boolean, Double)
Curve Boolean method, which trims and splits curves based on their overlapping regions.
Public methodStatic memberCreateBooleanUnion(IEnumerableCurve) Obsolete.
Calculates the boolean union of two or more closed, planar curves. Note, curves must be co-planar.
Public methodStatic memberCreateBooleanUnion(IEnumerableCurve, Double)
Calculates the boolean union of two or more closed, planar curves. Note, curves must be co-planar.
Public methodStatic memberCreateControlPointCurve(IEnumerablePoint3d)
Constructs a control-point of degree=3 (or less).
Public methodStatic memberCreateControlPointCurve(IEnumerablePoint3d, Int32)
Constructs a curve from a set of control-point locations.
Public methodStatic memberCreateCurve2View
Creates a third curve from two curves that are planar in different construction planes. The new curve looks the same as each of the original curves when viewed in each plane.
Public methodStatic memberCreateFillet
Computes the fillet arc for a curve filleting operation.
Public methodStatic memberCreateFilletCornersCurve
Rounds the corners of a kinked curve with arcs of a single, specified radius.
Public methodStatic memberCode exampleCreateFilletCurves
Creates a tangent arc between two curves and trims or extends the curves to the arc.
Public methodStatic memberCreateInterpolatedCurve(IEnumerablePoint3d, Int32)
Interpolates a sequence of points. Used by InterpCurve Command This routine works best when degree=3.
Public methodStatic memberCreateInterpolatedCurve(IEnumerablePoint3d, Int32, CurveKnotStyle)
Interpolates a sequence of points. Used by InterpCurve Command This routine works best when degree=3.
Public methodStatic memberCreateInterpolatedCurve(IEnumerablePoint3d, Int32, CurveKnotStyle, Vector3d, Vector3d)
Interpolates a sequence of points. Used by InterpCurve Command This routine works best when degree=3.
Public methodStatic memberCreateMatchCurve
Changes a curve end to meet a specified curve with a specified continuity.
Public methodStatic memberCreateMeanCurve(Curve, Curve)
Constructs a mean, or average, curve from two curves.
Public methodStatic memberCreateMeanCurve(Curve, Curve, Double)
Constructs a mean, or average, curve from two curves.
Public methodStatic memberCreatePeriodicCurve(Curve)
Removes kinks from a curve. Periodic curves deform smoothly without kinks.
Public methodStatic memberCreatePeriodicCurve(Curve, Boolean)
Removes kinks from a curve. Periodic curves deform smoothly without kinks.
Public methodStatic memberCreateSoftEditCurve
Creates a soft edited curve from an existing curve using a smooth field of influence.
Public methodStatic memberCreateTextOutlines
Creates outline curves created from a text string. The functionality is similar to what you find in Rhino's TextObject command or TextEntity.Explode() in RhinoCommon.
Public methodStatic memberCreateTweenCurves(Curve, Curve, Int32) Obsolete.
Creates curves between two open or closed input curves. Uses the control points of the curves for finding tween curves. That means the first control point of first curve is matched to first control point of the second curve and so on. There is no matching of curves direction. Caller must match input curves direction before calling the function.
Public methodStatic memberCreateTweenCurves(Curve, Curve, Int32, Double)
Creates curves between two open or closed input curves. Uses the control points of the curves for finding tween curves. That means the first control point of first curve is matched to first control point of the second curve and so on. There is no matching of curves direction. Caller must match input curves direction before calling the function.
Public methodStatic memberCreateTweenCurvesWithMatching(Curve, Curve, Int32) Obsolete.
Creates curves between two open or closed input curves. Make the structure of input curves compatible if needed. Refits the input curves to have the same structure. The resulting curves are usually more complex than input unless input curves are compatible and no refit is needed. There is no matching of curves direction. Caller must match input curves direction before calling the function.
Public methodStatic memberCreateTweenCurvesWithMatching(Curve, Curve, Int32, Double)
Creates curves between two open or closed input curves. Make the structure of input curves compatible if needed. Refits the input curves to have the same structure. The resulting curves are usually more complex than input unless input curves are compatible and no refit is needed. There is no matching of curves direction. Caller must match input curves direction before calling the function.
Public methodStatic memberCreateTweenCurvesWithSampling(Curve, Curve, Int32, Int32) Obsolete.
Creates curves between two open or closed input curves. Use sample points method to make curves compatible. This is how the algorithm works: Divides the two curves into an equal number of points, finds the midpoint between the corresponding points on the curves and interpolates the tween curve through those points. There is no matching of curves direction. Caller must match input curves direction before calling the function.
Public methodStatic memberCreateTweenCurvesWithSampling(Curve, Curve, Int32, Int32, Double)
Creates curves between two open or closed input curves. Use sample points method to make curves compatible. This is how the algorithm works: Divides the two curves into an equal number of points, finds the midpoint between the corresponding points on the curves and interpolates the tween curve through those points. There is no matching of curves direction. Caller must match input curves direction before calling the function.
Public methodCode exampleCurvatureAt
Evaluate the curvature vector at a curve parameter.
Public methodDerivativeAt(Double, Int32)
Evaluate the derivatives at the specified curve parameter.
Public methodDerivativeAt(Double, Int32, CurveEvaluationSide)
Evaluate the derivatives at the specified curve parameter.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

(Overrides GeometryBaseDispose(Boolean).)
Public methodDivideAsContour
Divides this curve at fixed steps along a defined contour line.
Public methodDivideByCount(Int32, Boolean)
Divide the curve into a number of equal-length segments.
Public methodDivideByCount(Int32, Boolean, Point3d)
Divide the curve into a number of equal-length segments.
Public methodCode exampleDivideByLength(Double, Boolean)
Divide the curve into specific length segments.
Public methodCode exampleDivideByLength(Double, Boolean, Point3d)
Divide the curve into specific length segments.
Public methodCode exampleDivideByLength(Double, Boolean, Boolean)
Divide the curve into specific length segments.
Public methodCode exampleDivideByLength(Double, Boolean, Boolean, Point3d)
Divide the curve into specific length segments.
Public methodDivideEquidistant
Calculates 3d points on a curve where the linear distance between the points is equal.
Public methodStatic memberDoDirectionsMatch
Determines whether two curves travel more or less in the same direction.
Public methodDuplicate
Constructs an exact duplicate of this Curve.
(Overrides GeometryBaseDuplicate.)
Public methodCode exampleDuplicateCurve
Constructs an exact duplicate of this curve.
Public methodDuplicateSegments
Duplicates curve segments. Explodes polylines, polycurves and G1 discontinuous NURBS curves. Single segment curves, such as lines, arcs, unkinked NURBS curves, are duplicated.
Public methodExtend(Interval)
Where possible, analytically extends curve to include the given domain. This will not work on closed curves. The original curve will be identical to the restriction of the resulting curve to the original curve domain.
Public methodExtend(Double, Double)
Where possible, analytically extends curve to include the given domain. This will not work on closed curves. The original curve will be identical to the restriction of the resulting curve to the original curve domain.
Public methodExtend(CurveEnd, CurveExtensionStyle, Point3d)
Extends a curve to a point.
Public methodCode exampleExtend(CurveEnd, CurveExtensionStyle, IEnumerableGeometryBase)
Extends a curve until it intersects a collection of objects.
Public methodExtend(CurveEnd, Double, CurveExtensionStyle)
Extends a curve by a specific length.
Public methodExtendByArc
Extends a curve by an Arc until it intersects a collection of objects.
Public methodExtendByLine
Extends a curve by a line until it intersects a collection of objects.
Public methodExtendOnSurface(CurveEnd, BrepFace)
Extends a curve on a surface.
Public methodExtendOnSurface(CurveEnd, Surface)
Extends a curve on a surface.
Public methodExtremeParameters
Returns the parameter values of all local extrema. Parameter values are in increasing order so consecutive extrema define an interval on which each component of the curve is monotone. Note, non-periodic curves always return the end points.
Public methodFair
Fairs a curve object. Fair works best on degree 3 (cubic) curves. Attempts to remove large curvature variations while limiting the geometry changes to be no more than the specified tolerance.
Public methodFilletSurfaceToCurve
Creates a constant-radius fillet surface between a surface and the curve.
Public methodFilletSurfaceToRail
Creates a surface between two surfaces, with a fixed rail curve on the first surface.
Public methodFindLocalInflection
Local minimization for point on a curve with tangent perpendicular to N.
Public methodFit
Fits a new curve through an existing curve.
Public methodFrameAt
Returns a 3d frame at a parameter.
Public methodGetConicSectionType
Returns the type of conic section based on the curve's shape.
Public methodGetConicSectionType(Point3d, Point3d, Point3d)
Returns the type of conic section based on the curve's shape.
Public methodGetCurveParameterFromNurbsFormParameter
Convert a NURBS curve parameter to a curve parameter.
Public methodStatic memberCode exampleGetDistancesBetweenCurves
Calculates the minimum and maximum distances between two curves. This function is useful for computing curve deviation. If you are not computing curve deviation, use .
Public methodStatic memberGetFilletPoints
Finds points at which to cut a pair of curves so that a fillet of given radius can be inserted.
Public methodCode exampleGetLength
Gets the length of the curve with a fractional tolerance of 1.0e-8.
Public methodGetLength(Double)
Get the length of the curve.
Public methodGetLength(Interval)
Get the length of a sub-section of the curve with a fractional tolerance of 1e-8.
Public methodGetLength(Double, Interval)
Get the length of a sub-section of the curve.
Public methodGetLocalPerpPoint(Point3d, Double, Double)
Search for a location on the curve, near seedParmameter, that is perpendicular to a test point.
Public methodGetLocalPerpPoint(Point3d, Double, Interval, Double)
Search for a location on the curve, near seedParmameter, that is perpendicular to a test point.
Public methodGetLocalTangentPoint(Point3d, Double, Double)
Search for a location on the curve, near seedParmameter, that is tangent to a test point.
Public methodGetLocalTangentPoint(Point3d, Double, Interval, Double)
Search for a location on the curve, near seedParmameter, that is tangent to a test point.
Public methodGetNextDiscontinuity(Continuity, Double, Double, Double)
Searches for a derivative, tangent, or curvature discontinuity.
Public methodGetNextDiscontinuity(Continuity, Double, Double, Double, Double, Double)
Searches for a derivative, tangent, or curvature discontinuity.
Public methodGetNurbsFormParameterFromCurveParameter
Convert a curve parameter to a NURBS curve parameter.
Public methodGetPerpendicularFrames
Gets a collection of perpendicular frames along the curve. Perpendicular frames are also known as 'Zero-twisting frames' and they minimize rotation from one frame to the next.
Public methodHasNurbsForm
Does a NURBS curve representation of this curve exist?
Public methodInflectionPoints
Returns a curve's inflection points. An inflection point is a location on a curve at which the sign of the curvature (i.e., the concavity) changes. The curvature at these locations is always 0.
Public methodInflectionPoints(Double)
Returns a curve's inflection points. An inflection point is a location on a curve at which the sign of the curvature (i.e., the concavity) changes. The curvature at these locations is always 0.
Public methodIsArc
Test a curve to see if it can be represented by an arc or circle within RhinoMath.ZeroTolerance.
Public methodIsArc(Double)
Test a curve to see if it can be represented by an arc or circle within the given tolerance.
Public methodIsCircle
Test a curve to see if it can be represented by a circle within RhinoMath.ZeroTolerance.
Public methodIsCircle(Double)
Test a curve to see if it can be represented by a circle within the given tolerance.
Public methodIsClosable(Double)
Decide if it makes sense to close off this curve by moving the endpoint to the start based on start-end gap size and length of curve as approximated by chord defined by 6 points.
Public methodIsClosable(Double, Double, Double)
Decide if it makes sense to close off this curve by moving the endpoint to the start based on start-end gap size and length of curve as approximated by chord defined by 6 points.
Public methodIsContinuous
Test continuity at a curve parameter value.
Public methodIsEllipse
Test a curve to see if it can be represented by an ellipse within RhinoMath.ZeroTolerance.
Public methodIsEllipse(Double)
Test a curve to see if it can be represented by an ellipse within a given tolerance.
Public methodIsInPlane(Plane)
Test a curve to see if it lies in a specific plane.
Public methodIsInPlane(Plane, Double)
Test a curve to see if it lies in a specific plane.
Public methodCode exampleIsLinear
Test a curve to see if it is linear to within RhinoMath.ZeroTolerance units (1e-12).
Public methodIsLinear(Double)
Test a curve to see if it is linear to within the custom tolerance.
Public methodCode exampleIsPlanar
Test a curve for planarity.
Public methodIsPlanar(Double)
Test a curve for planarity.
Public methodCode exampleIsPolyline
Several types of Curve can have the form of a polyline including a degree 1 NurbsCurve, a PolylineCurve, and a PolyCurve all of whose segments are some form of polyline. IsPolyline tests a curve to see if it can be represented as a polyline.
Public methodCode exampleIsShort(Double)
Used to quickly find short curves.
Public methodIsShort(Double, Interval)
Used to quickly find short curves.
Public methodStatic memberJoinCurves(IEnumerableCurve)
Joins a collection of curve segments together.
Public methodStatic memberCode exampleJoinCurves(IEnumerableCurve, Double)
Joins a collection of curve segments together.
Public methodStatic memberJoinCurves(IEnumerableCurve, Double, Boolean)
Joins a collection of curve segments together.
Public methodStatic memberJoinCurves(IEnumerableCurve, Double, Boolean, Int32)
Joins a collection of curve segments together.
Public methodLengthParameter(Double, Double)
Gets the parameter along the curve which coincides with a given length along the curve. A fractional tolerance of 1e-8 is used in this version of the function.
Public methodLengthParameter(Double, Double, Interval)
Gets the parameter along the curve which coincides with a given length along the curve. A fractional tolerance of 1e-8 is used in this version of the function.
Public methodLengthParameter(Double, Double, Double)
Gets the parameter along the curve which coincides with a given length along the curve.
Public methodLengthParameter(Double, Double, Double, Interval)
Gets the parameter along the curve which coincides with a given length along the curve.
Public methodLocalClosestPoint
Find parameter of the point on a curve that is locally closest to the testPoint. The search for a local close point starts at a seed parameter.
Public methodMakeClosed
If IsClosed, just return true. Otherwise, decide if curve can be closed as follows: Linear curves polylinear curves with 2 segments, NURBS with 3 or less control points cannot be made closed. Also, if tolerance > 0 and the gap between start and end is larger than tolerance, curve cannot be made closed. Adjust the curve's endpoint to match its start point.
Public methodStatic memberMakeEndsMeet
Makes adjustments to the ends of one or both input curves so that they meet at a point.
Public methodMaxCurvaturePoints
Returns a curve's maximum curvature points. The maximum curvature points identify where the curvature starts to decrease in both directions from the points.
Public methodMaxCurvaturePoints(Double)
Returns a curve's maximum curvature points. The maximum curvature points identify where the curvature starts to decrease in both directions from the points.
Protected methodNonConstOperation
For derived classes implementers.

Defines the necessary implementation to free the instance from being constant.

(Overrides GeometryBaseNonConstOperation.)
Public methodNormalizedLengthParameter(Double, Double)
Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve. A fractional tolerance of 1e-8 is used in this version of the function.
Public methodNormalizedLengthParameter(Double, Double, Interval)
Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve. A fractional tolerance of 1e-8 is used in this version of the function.
Public methodNormalizedLengthParameter(Double, Double, Double)
Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve.
Public methodNormalizedLengthParameter(Double, Double, Double, Interval)
Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve.
Public methodNormalizedLengthParameters(Double, Double)
Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve. A fractional tolerance of 1e-8 is used in this version of the function.
Public methodNormalizedLengthParameters(Double, Double, Interval)
Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve. A fractional tolerance of 1e-8 is used in this version of the function.
Public methodNormalizedLengthParameters(Double, Double, Double)
Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve.
Public methodNormalizedLengthParameters(Double, Double, Double, Interval)
Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve.
Public methodOffset(Plane, Double, Double, CurveOffsetCornerStyle)
Offsets this curve. If you have a nice offset, then there will be one entry in the array. If the original curve had kinks or the offset curve had self intersections, you will get multiple segments in the output array.
Public methodOffset(Point3d, Vector3d, Double, Double, CurveOffsetCornerStyle)
Offsets this curve. If you have a nice offset, then there will be one entry in the array. If the original curve had kinks or the offset curve had self intersections, you will get multiple segments in the output array.
Public methodOffset(Point3d, Vector3d, Double, Double, Double, Boolean, CurveOffsetCornerStyle, CurveOffsetEndStyle)
Offsets this curve. If you have a nice offset, then there will be one entry in the array. If the original curve had kinks or the offset curve had self intersections, you will get multiple segments in the output array.
Public methodOffsetNormalToSurface
Finds a curve by offsetting an existing curve normal to a surface. The caller is responsible for ensuring that the curve lies on the input surface.
Public methodOffsetOnSurface(BrepFace, Point2d, Double)
Offset a curve on a brep face surface. This curve must lie on the surface.

This overload allows to specify a surface point at which the offset will pass.

Public methodOffsetOnSurface(BrepFace, Double, Double)
Offset this curve on a brep face surface. This curve must lie on the surface.
Public methodOffsetOnSurface(Surface, Point2d, Double)
Offset a curve on a surface. This curve must lie on the surface.

This overload allows to specify a surface point at which the offset will pass.

Public methodOffsetOnSurface(Surface, Double, Double)
Offset a curve on a surface. This curve must lie on the surface.
Public methodOffsetOnSurface(BrepFace, Double, Double, Double)
Offset a curve on a brep face surface. This curve must lie on the surface.

This overload allows to specify different offsets for different curve parameters.

Public methodOffsetOnSurface(Surface, Double, Double, Double)
Offset this curve on a surface. This curve must lie on the surface.

This overload allows to specify different offsets for different curve parameters.

Public methodOffsetTangentToSurface
Finds a curve by offsetting an existing curve tangent to a surface. The caller is responsible for ensuring that the curve lies on the input surface.
Public methodPerpendicularFrameAt
Return a 3d frame at a parameter. This is slightly different than FrameAt in that the frame is computed in a way so there is minimal rotation from one frame to the next.
Public methodStatic memberPlanarClosedCurveRelationship
Determines whether two coplanar simple closed curves are disjoint or intersect; otherwise, if the regions have a containment relationship, discovers which curve encloses the other.
Public methodStatic memberPlanarCurveCollision
Determines if two coplanar curves collide (intersect).
Public methodCode examplePointAt
Evaluates point at a curve parameter.
Public methodCode examplePointAtLength
Gets a point at a certain length along the curve. The length must be non-negative and less than or equal to the length of the curve. Lengths will not be wrapped when the curve is closed or periodic.
Public methodPointAtNormalizedLength
Gets a point at a certain normalized length along the curve. The length must be between or including 0.0 and 1.0, where 0.0 equals the start of the curve and 1.0 equals the end of the curve.
Public methodStatic memberProjectToBrep(Curve, Brep, Vector3d, Double)
Projects a Curve onto a Brep along a given direction.
Public methodStatic memberProjectToBrep(Curve, IEnumerableBrep, Vector3d, Double)
Projects a Curve onto a collection of Breps along a given direction.
Public methodStatic memberProjectToBrep(IEnumerableCurve, IEnumerableBrep, Vector3d, Double)
Projects a collection of Curves onto a collection of Breps along a given direction.
Public methodStatic memberProjectToBrep(Curve, IEnumerableBrep, Vector3d, Double, Int32)
Projects a Curve onto a collection of Breps along a given direction.
Public methodStatic memberProjectToBrep(IEnumerableCurve, IEnumerableBrep, Vector3d, Double, Int32, Int32)
Projects a collection of Curves onto a collection of Breps along a given direction.
Public methodStatic memberProjectToMesh(Curve, Mesh, Vector3d, Double)
Projects a curve to a mesh using a direction and tolerance.
Public methodStatic memberProjectToMesh(Curve, IEnumerableMesh, Vector3d, Double)
Projects a curve to a set of meshes using a direction and tolerance.
Public methodStatic memberProjectToMesh(IEnumerableCurve, IEnumerableMesh, Vector3d, Double)
Projects a curve to a set of meshes using a direction and tolerance.
Public methodStatic memberProjectToPlane
Constructs a curve by projecting an existing curve to a plane.
Public methodPullToBrepFace(BrepFace, Double)
Pulls this curve to a brep face and returns the result of that operation.
Public methodStatic memberPullToBrepFace(Curve, BrepFace, Double)
Pull a curve to a BrepFace using closest point projection.
Public methodPullToMesh
Makes a polyline approximation of the curve and gets the closest point on the mesh for each point on the curve. Then it "connects the points" so that you have a polyline on the mesh.
Public methodRebuild
Rebuild a curve with a specific point count.
Public methodRemoveShortSegments
Looks for segments that are shorter than tolerance that can be removed. Does not change the domain, but it will change the relative parameterization.
Public methodCode exampleReverse
Reverses the direction of the curve.
Public methodRibbonOffset(Double, Double, Point3d, Vector3d, Double)
Offsets a closed curve in the following way: pProject the curve to a plane with given normal. Then, loose Offset the projection by distance + blend_radius and trim off self-intersection. THen, Offset the remaining curve back in the opposite direction by blend_radius, filling gaps with blends. Finally, use the elevations of the input curve to get the correct elevations of the result.
Public methodRibbonOffset(Double, Double, Point3d, Vector3d, Double, Curve, Surface)
Offsets a closed curve in the following way: pProject the curve to a plane with given normal. Then, loose Offset the projection by distance + blend_radius and trim off self-intersection. THen, Offset the remaining curve back in the opposite direction by blend_radius, filling gaps with blends. Finally, use the elevations of the input curve to get the correct elevations of the result.
Public methodRibbonOffset(Double, Double, Point3d, Vector3d, Double, Double, Double)
Offsets a closed curve in the following way: pProject the curve to a plane with given normal. Then, loose Offset the projection by distance + blend_radius and trim off self-intersection. THen, Offset the remaining curve back in the opposite direction by blend_radius, filling gaps with blends. Finally, use the elevations of the input curve to get the correct elevations of the result.
Public methodSetEndPoint
Forces the curve to end at a specified point. Not all curve types support this operation.
Public methodSetStartPoint
Forces the curve to start at a specified point. Not all curve types support this operation.
Public methodSimplify
Returns a geometrically equivalent PolyCurve.

The PolyCurve has the following properties

1. All the PolyCurve segments are LineCurve, PolylineCurve, ArcCurve, or NurbsCurve.

2. The NURBS Curves segments do not have fully multiple interior knots.

3. Rational NURBS curves do not have constant weights.

4. Any segment for which IsLinear() or IsArc() is true is a Line, Polyline segment, or an Arc.

5. Adjacent co-linear or co-circular segments are combined.

6. Segments that meet with G1-continuity have there ends tuned up so that they meet with G1-continuity to within machine precision.

Public methodSimplifyEnd
Same as SimplifyCurve, but simplifies only the last two segments at "side" end.
Public methodSmooth(Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem)
Smooths a curve by averaging the positions of control points in a specified region.
Public methodSmooth(Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem, Plane)
Smooths a curve by averaging the positions of control points in a specified region.
Public methodSpanDomain
Get the domain of the curve span with the given index. Use the SpanCount property to test how many spans there are.
Public methodSplit(Double)
Splits (divides) the curve at the specified parameter. The parameter must be in the interior of the curve's domain.
Public methodSplit(IEnumerableDouble)
Splits (divides) the curve at a series of specified parameters. The parameter must be in the interior of the curve domain.
Public methodSplit(Brep, Double) Obsolete.
Splits a curve into pieces using a polysurface.
Public methodSplit(Surface, Double) Obsolete.
Splits a curve into pieces using a surface.
Public methodSplit(Brep, Double, Double)
Splits a curve into pieces using a polysurface.
Public methodSplit(Surface, Double, Double)
Splits a curve into pieces using a surface.
Public methodTangentAt
Evaluates the unit tangent vector at a curve parameter.
Public methodToArcsAndLines
Converts a curve into polycurve consisting of arc segments. Sections of the input curves that are nearly straight are converted to straight-line segments.
Public methodToNurbsCurve
Constructs a NURBS curve representation of this curve.
Public methodToNurbsCurve(Interval)
Constructs a NURBS curve representation of this curve.
Public methodToPolyline(Double, Double, Double, Double)
Gets a polyline approximation of a curve.
Public methodToPolyline(Int32, Int32, Double, Double, Double, Double, Double, Double, Boolean)
Gets a polyline approximation of a curve.
Public methodToPolyline(Int32, Int32, Double, Double, Double, Double, Double, Double, Boolean, Interval)
Gets a polyline approximation of a curve.
Public methodTorsionAt
Evaluate the torsion of a curve at a parameter. Sometimes also called the "second curvature", torsion is the rate of change of a curve's osculating plane.
Public methodTrim(Interval)
Removes portions of the curve outside the specified interval.
Public methodTrim(CurveEnd, Double)
Shortens a curve by a given length
Public methodTrim(Double, Double)
Removes portions of the curve outside the specified interval.
Public methodTryGetArc(Arc)
Try to convert this curve into an Arc using RhinoMath.ZeroTolerance.
Public methodTryGetArc(Arc, Double)
Try to convert this curve into an Arc using a custom tolerance.
Public methodTryGetArc(Plane, Arc)
Try to convert this curve into an Arc using RhinoMath.ZeroTolerance.
Public methodTryGetArc(Plane, Arc, Double)
Try to convert this curve into an Arc using a custom tolerance.
Public methodCode exampleTryGetCircle(Circle)
Try to convert this curve into a circle using RhinoMath.ZeroTolerance.
Public methodCode exampleTryGetCircle(Circle, Double)
Try to convert this curve into a Circle using a custom tolerance.
Public methodTryGetEllipse(Ellipse)
Try to convert this curve into an Ellipse within RhinoMath.ZeroTolerance.
Public methodTryGetEllipse(Ellipse, Double)
Try to convert this curve into an Ellipse using a custom tolerance.
Public methodTryGetEllipse(Plane, Ellipse)
Try to convert this curve into an Ellipse within RhinoMath.ZeroTolerance.
Public methodTryGetEllipse(Plane, Ellipse, Double)
Try to convert this curve into an Ellipse using a custom tolerance.
Public methodCode exampleTryGetPlane(Plane)
Test a curve for planarity and return the plane.
Public methodTryGetPlane(Plane, Double)
Test a curve for planarity and return the plane.
Public methodTryGetPolyline(Polyline)
Several types of Curve can have the form of a polyline including a degree 1 NurbsCurve, a PolylineCurve, and a PolyCurve all of whose segments are some form of polyline. IsPolyline tests a curve to see if it can be represented as a polyline.
Public methodTryGetPolyline(Polyline, Double)
Several types of Curve can have the form of a polyline including a degree 1 NurbsCurve, a PolylineCurve, and a PolyCurve all of whose segments are some form of polyline. IsPolyline tests a curve to see if it can be represented as a polyline.
Top
See Also
Inheritance Hierarchy