Click or drag to resize

CurveGetLocalTangentPoint Method (Point3d, Double, Interval, Double)

Search for a location on the curve, near seedParmameter, that is tangent to a test point.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public bool GetLocalTangentPoint(
	Point3d testPoint,
	double seedParmameter,
	Interval subDomain,
	out double curveParameter
)

Parameters

testPoint
Type: Rhino.GeometryPoint3d
The test point.
seedParmameter
Type: SystemDouble
A "seed" parameter on the curve.
subDomain
Type: Rhino.GeometryInterval
The sub-domain of the curve to search.
curveParameter
Type: SystemDouble
The parameter value at the tangent point

Return Value

Type: Boolean
True if a solution is found, false otherwise.
See Also