Click or drag to resize

CurveLengthParameter Method (Double, Double, Double)

Gets the parameter along the curve which coincides with a given length along the curve.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool LengthParameter(
	double segmentLength,
	out double t,
	double fractionalTolerance
)

Parameters

segmentLength
Type: SystemDouble
Length of segment to measure. Must be less than or equal to the length of the curve.
t
Type: SystemDouble
Parameter such that the length of the curve from the curve start point to t equals s.
fractionalTolerance
Type: SystemDouble
Desired fractional precision. fabs(("exact" length from start to t) - arc_length)/arc_length <= fractionalTolerance.

Return Value

Type: Boolean
true on success, false on failure.
See Also