Click or drag to resize

CurvePullToBrepFace Method (BrepFace, Double)

Pulls this curve to a brep face and returns the result of that operation.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Curve[] PullToBrepFace(
	BrepFace face,
	double tolerance
)

Parameters

face
Type: Rhino.GeometryBrepFace
A brep face.
tolerance
Type: SystemDouble
A tolerance value.

Return Value

Type: Curve
An array containing the resulting curves after pulling. This array could be empty.
Exceptions
ExceptionCondition
ArgumentNullExceptionIf face is null.
See Also