CurvePullToBrepFace Method (Curve, BrepFace, Double) |
Pull a curve to a BrepFace using closest point projection.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public static Curve[] PullToBrepFace(
Curve curve,
BrepFace face,
double tolerance
)
Public Shared Function PullToBrepFace (
curve As Curve,
face As BrepFace,
tolerance As Double
) As Curve()
Parameters
- curve
- Type: Rhino.GeometryCurve
Curve to pull. - face
- Type: Rhino.GeometryBrepFace
Brep face that pulls. - tolerance
- Type: SystemDouble
Tolerance to use for pulling.
Return Value
Type:
CurveAn array of pulled curves, or an empty array on failure.
See Also