Click or drag to resize

CurveSetStartPoint Method

Forces the curve to start at a specified point. Not all curve types support this operation.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool SetStartPoint(
	Point3d point
)

Parameters

point
Type: Rhino.GeometryPoint3d
New start point of curve.

Return Value

Type: Boolean
true on success, false on failure.
Remarks
Some start points cannot be moved. Be sure to check return code.
See Also