Click or drag to resize

CurveSimplify Method

Returns a geometrically equivalent PolyCurve.

The PolyCurve has the following properties

1. All the PolyCurve segments are LineCurve, PolylineCurve, ArcCurve, or NurbsCurve.

2. The NURBS Curves segments do not have fully multiple interior knots.

3. Rational NURBS curves do not have constant weights.

4. Any segment for which IsLinear() or IsArc() is true is a Line, Polyline segment, or an Arc.

5. Adjacent co-linear or co-circular segments are combined.

6. Segments that meet with G1-continuity have there ends tuned up so that they meet with G1-continuity to within machine precision.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Curve Simplify(
	CurveSimplifyOptions options,
	double distanceTolerance,
	double angleToleranceRadians
)

Parameters

options
Type: Rhino.GeometryCurveSimplifyOptions
Simplification options.
distanceTolerance
Type: SystemDouble
A distance tolerance for the simplification.
angleToleranceRadians
Type: SystemDouble
An angle tolerance for the simplification.

Return Value

Type: Curve
New simplified curve on success, null on failure.
See Also