Click or drag to resize

CurveFit Method

Fits a new curve through an existing curve.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Curve Fit(
	int degree,
	double fitTolerance,
	double angleTolerance
)

Parameters

degree
Type: SystemInt32
The degree of the returned Curve. Must be bigger than 1.
fitTolerance
Type: SystemDouble
The fitting tolerance. If fitTolerance is RhinoMath.UnsetValue or <=0.0, the document absolute tolerance is used.
angleTolerance
Type: SystemDouble
The kink smoothing tolerance in radians.

If angleTolerance is 0.0, all kinks are smoothed

If angleTolerance is >0.0, kinks smaller than angleTolerance are smoothed

If angleTolerance is RhinoMath.UnsetValue or <0.0, the document angle tolerance is used for the kink smoothing

Return Value

Type: Curve
Returns a new fitted Curve if successful, null on failure.
See Also