Click or drag to resize

CurveGetPerpendicularFrames Method

Gets a collection of perpendicular frames along the curve. Perpendicular frames are also known as 'Zero-twisting frames' and they minimize rotation from one frame to the next.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Plane[] GetPerpendicularFrames(
	IEnumerable<double> parameters
)

Parameters

parameters
Type: System.Collections.GenericIEnumerableDouble
A collection of strictly increasing curve parameters to place perpendicular frames on.

Return Value

Type: Plane
An array of perpendicular frames on success or null on failure.
Exceptions
ExceptionCondition
InvalidOperationExceptionThrown when the curve parameters are not increasing.
See Also