CurvePlanarCurveCollision Method |
Determines if two coplanar curves collide (intersect).
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public static bool PlanarCurveCollision(
Curve curveA,
Curve curveB,
Plane testPlane,
double tolerance
)
Public Shared Function PlanarCurveCollision (
curveA As Curve,
curveB As Curve,
testPlane As Plane,
tolerance As Double
) As Boolean
Parameters
- curveA
- Type: Rhino.GeometryCurve
A curve. - curveB
- Type: Rhino.GeometryCurve
Another curve. - testPlane
- Type: Rhino.GeometryPlane
A valid plane containing the curves. - tolerance
- Type: SystemDouble
A tolerance value for intersection.
Return Value
Type:
Booleantrue if the curves intersect, otherwise false
See Also