CurveTryGetEllipse Method (Ellipse, Double) |
Try to convert this curve into an Ellipse using a custom tolerance.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool TryGetEllipse(
out Ellipse ellipse,
double tolerance
)
Public Function TryGetEllipse (
<OutAttribute> ByRef ellipse As Ellipse,
tolerance As Double
) As Boolean
Parameters
- ellipse
- Type: Rhino.GeometryEllipse
On success, the Ellipse will be filled in. - tolerance
- Type: SystemDouble
Tolerance to use when checking.
Return Value
Type:
Booleantrue if the curve could be converted into an Ellipse.
See Also