Click or drag to resize

CurveTryGetEllipse Method (Plane, Ellipse)

Try to convert this curve into an Ellipse within RhinoMath.ZeroTolerance.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool TryGetEllipse(
	Plane plane,
	out Ellipse ellipse
)

Parameters

plane
Type: Rhino.GeometryPlane
Plane in which the comparison is performed.
ellipse
Type: Rhino.GeometryEllipse
On success, the Ellipse will be filled in.

Return Value

Type: Boolean
true if the curve could be converted into an Ellipse within the given plane.
See Also