CurveGetLength Method (Double) |
Get the length of the curve.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public double GetLength(
double fractionalTolerance
)
Public Function GetLength (
fractionalTolerance As Double
) As Double
Parameters
- fractionalTolerance
- Type: SystemDouble
Desired fractional precision.
fabs(("exact" length from start to t) - arc_length)/arc_length <= fractionalTolerance.
Return Value
Type:
DoubleThe length of the curve on success, or zero on failure.
See Also