Click or drag to resize

CurveGetLength Method (Interval)

Get the length of a sub-section of the curve with a fractional tolerance of 1e-8.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public double GetLength(
	Interval subdomain
)

Parameters

subdomain
Type: Rhino.GeometryInterval
The calculation is performed on the specified sub-domain of the curve (must be non-decreasing).

Return Value

Type: Double
The length of the sub-curve on success, or zero on failure.
See Also