Click or drag to resize

CurveOffsetOnSurface Method (Surface, Double, Double, Double)

Offset this curve on a surface. This curve must lie on the surface.

This overload allows to specify different offsets for different curve parameters.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Curve[] OffsetOnSurface(
	Surface surface,
	double[] curveParameters,
	double[] offsetDistances,
	double fittingTolerance
)

Parameters

surface
Type: Rhino.GeometrySurface
A surface on which to offset.
curveParameters
Type: SystemDouble
Curve parameters corresponding to the offset distances.
offsetDistances
Type: SystemDouble
Distances to offset (+)left, (-)right.
fittingTolerance
Type: SystemDouble
A fitting tolerance.

Return Value

Type: Curve
Offset curves on success, or null on failure.
Exceptions
ExceptionCondition
ArgumentNullExceptionIf surface, curveParameters or offsetDistances are null.
See Also