CurveOffsetOnSurface Method (Surface, Double, Double) |
Offset a curve on a surface. This curve must lie on the surface.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public Curve[] OffsetOnSurface(
Surface surface,
double distance,
double fittingTolerance
)
Public Function OffsetOnSurface (
surface As Surface,
distance As Double,
fittingTolerance As Double
) As Curve()
Parameters
- surface
- Type: Rhino.GeometrySurface
A surface on which to offset. - distance
- Type: SystemDouble
A distance to offset (+)left, (-)right. - fittingTolerance
- Type: SystemDouble
A fitting tolerance.
Return Value
Type:
CurveOffset curves on success, or null on failure.
Exceptions See Also