Click or drag to resize

CurveCreateMeanCurve Method (Curve, Curve)

Constructs a mean, or average, curve from two curves.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static Curve CreateMeanCurve(
	Curve curveA,
	Curve curveB
)

Parameters

curveA
Type: Rhino.GeometryCurve
A first curve.
curveB
Type: Rhino.GeometryCurve
A second curve.

Return Value

Type: Curve
The average curve, or null on error.
Exceptions
ExceptionCondition
ArgumentNullExceptionIf curveA or curveB are null.
See Also