CurveExtendOnSurface Method (CurveEnd, BrepFace) |
Extends a curve on a surface.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public Curve ExtendOnSurface(
CurveEnd side,
BrepFace face
)
Public Function ExtendOnSurface (
side As CurveEnd,
face As BrepFace
) As Curve
Parameters
- side
- Type: Rhino.GeometryCurveEnd
The end of the curve to extend. - face
- Type: Rhino.GeometryBrepFace
BrepFace that contains the curve.
Return Value
Type:
CurveNew extended curve result on success, null on failure.
See Also