Click or drag to resize

CurveNormalizedLengthParameter Method (Double, Double, Double)

Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool NormalizedLengthParameter(
	double s,
	out double t,
	double fractionalTolerance
)

Parameters

s
Type: SystemDouble
Normalized arc length parameter. E.g., 0 = start of curve, 1/2 = midpoint of curve, 1 = end of curve.
t
Type: SystemDouble
Parameter such that the length of the curve from its start to t is arc_length.
fractionalTolerance
Type: SystemDouble
Desired fractional precision. fabs(("exact" length from start to t) - arc_length)/arc_length <= fractionalTolerance.

Return Value

Type: Boolean
true on success, false on failure.
See Also