CurveJoinCurves Method (IEnumerableCurve, Double, Boolean) |
Joins a collection of curve segments together.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public static Curve[] JoinCurves(
IEnumerable<Curve> inputCurves,
double joinTolerance,
bool preserveDirection
)
Public Shared Function JoinCurves (
inputCurves As IEnumerable(Of Curve),
joinTolerance As Double,
preserveDirection As Boolean
) As Curve()
Parameters
- inputCurves
- Type: System.Collections.GenericIEnumerableCurve
An array, a list or any enumerable set of curve segments to join. - joinTolerance
- Type: SystemDouble
Joining tolerance,
i.e. the distance between segment end-points that is allowed. - preserveDirection
- Type: SystemBoolean
If true, curve endpoints will be compared to curve start points.
If false, all start and endpoints will be compared and copies of input curves may be reversed in output.
Return Value
Type:
CurveAn array of joined curves. This array can be empty.
Exceptions See Also