Click or drag to resize

CurveClosestPoint Method (Point3d, Double, Double)

Finds the parameter of the point on a curve that is closest to testPoint. If the maximumDistance parameter is > 0, then only points whose distance to the given point is <= maximumDistance will be returned. Using a positive value of maximumDistance can substantially speed up the search.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool ClosestPoint(
	Point3d testPoint,
	out double t,
	double maximumDistance
)

Parameters

testPoint
Type: Rhino.GeometryPoint3d
Point to project.
t
Type: SystemDouble
parameter of local closest point returned here.
maximumDistance
Type: SystemDouble
The maximum allowed distance.

Past this distance, the search is given up and false is returned.

Use 0 to turn off this parameter.

Return Value

Type: Boolean
true on success, false on failure.
See Also