CurveCreateInterpolatedCurve Method (IEnumerablePoint3d, Int32, CurveKnotStyle, Vector3d, Vector3d) |
Interpolates a sequence of points. Used by InterpCurve Command
This routine works best when degree=3.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public static Curve CreateInterpolatedCurve(
IEnumerable<Point3d> points,
int degree,
CurveKnotStyle knots,
Vector3d startTangent,
Vector3d endTangent
)
Public Shared Function CreateInterpolatedCurve (
points As IEnumerable(Of Point3d),
degree As Integer,
knots As CurveKnotStyle,
startTangent As Vector3d,
endTangent As Vector3d
) As Curve
Parameters
- points
- Type: System.Collections.GenericIEnumerablePoint3d
Points to interpolate. For periodic curves if the final point is a
duplicate of the initial point it is ignored. (Count must be >=2)
- degree
- Type: SystemInt32
The degree of the curve >=1. Note: Even degree > 3 periodic interpolation
results in a non-periodic closed curve. - knots
- Type: Rhino.GeometryCurveKnotStyle
Knot-style to use and specifies if the curve should be periodic.
- startTangent
- Type: Rhino.GeometryVector3d
A starting tangent. - endTangent
- Type: Rhino.GeometryVector3d
An ending tangent.
Return Value
Type:
Curveinterpolated curve on success. null on failure.
See Also