Click or drag to resize

CurveCreateBooleanIntersection Method (Curve, Curve)

Note: This API is now obsolete.

Calculates the boolean intersection of two closed, planar curves. Note, curves must be co-planar.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
[ObsoleteAttribute("Use version that takes tolerance as input")]
public static Curve[] CreateBooleanIntersection(
	Curve curveA,
	Curve curveB
)

Parameters

curveA
Type: Rhino.GeometryCurve
The first closed, planar curve.
curveB
Type: Rhino.GeometryCurve
The second closed, planar curve.

Return Value

Type: Curve
Result curves on success, empty array if no intersection could be calculated.
See Also