Click or drag to resize

CurveIsClosable Method (Double, Double, Double)

Decide if it makes sense to close off this curve by moving the endpoint to the start based on start-end gap size and length of curve as approximated by chord defined by 6 points.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool IsClosable(
	double tolerance,
	double minimumAbsoluteSize,
	double minimumRelativeSize
)

Parameters

tolerance
Type: SystemDouble
Maximum allowable distance between start and end. If start - end gap is greater than tolerance, this function will return false.
minimumAbsoluteSize
Type: SystemDouble
If greater than 0.0 and none of the interior sampled points are at least minimumAbsoluteSize from start, this function will return false.
minimumRelativeSize
Type: SystemDouble
If greater than 1.0 and chord length is less than minimumRelativeSize*gap, this function will return false.

Return Value

Type: Boolean
true if start and end points are close enough based on above conditions.
See Also