Click or drag to resize

PointCloud Class

Represents a collection of coordinates with optional normal vectors and colors.
Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class PointCloud : GeometryBase, IEnumerable<PointCloudItem>, 
	IEnumerable

The PointCloud type exposes the following members.

Constructors
  NameDescription
Public methodPointCloud
Initializes a new instance of the PointCloud class that is empty.
Public methodPointCloud(IEnumerablePoint3d)
Initializes a new instance of the PointCloud class, copying the content from a set of points.
Public methodPointCloud(PointCloud)
Initializes a new instance of the PointCloud class, copying (Merge) the content of another point cloud.
Protected methodPointCloud(SerializationInfo, StreamingContext)
Binds with the Rhino default serializer to support object persistence.
Top
Properties
  NameDescription
Public propertyContainsColors
Gets a value indicating whether or not the points in this point cloud have colors assigned to them.
Public propertyContainsHiddenFlags
Gets a value indicating whether or not the points in this point cloud have hidden flags assigned to them.
Public propertyContainsNormals
Gets a value indicating whether or not the points in this point cloud have normals assigned to them.
Public propertyContainsPointValues
Gets a value indicating whether or not the points in this point cloud have extra values assigned to them. Extra values can be used to store a user-defined values, such as intensity.
Public propertyCount
Gets the number of points in this point cloud.
Public propertyHiddenPointCount
Gets the number of points that have their Hidden flag set.
Public propertyItem
Gets the item at the given index.
Top
Methods
  NameDescription
Public methodAdd(Point3d)
Append a new point to the end of the list.
Public methodAdd(Point3d, Vector3d)
Append a new point to the end of the list.
Public methodAdd(Point3d, Color)
Append a new point to the end of the list.
Public methodAdd(Point3d, Vector3d, Color)
Append a new point to the end of the list.
Public methodAdd(Point3d, Vector3d, Color, Double)
Append a new point to the end of the list.
Public methodAddRange(IEnumerablePoint3d)
Appends a collection of points to this point cloud.
Public methodAddRange(IEnumerablePoint3d, IEnumerableVector3d)
Appends a collection of points and normal vectors to this point cloud.
Public methodAddRange(IEnumerablePoint3d, IEnumerableColor)
Appends a collection of points and normal vectors to this point cloud.
Public methodAddRange(IEnumerablePoint3d, IEnumerableVector3d, IEnumerableColor)
Appends a collection of points, normal vectors, and colors to this point cloud.
Public methodAddRange(IEnumerablePoint3d, IEnumerableVector3d, IEnumerableColor, IEnumerableDouble)
Appends a collection of points, normal vectors, colors, and extra values to this point cloud.
Public methodAppendNew
Appends a new PointCloudItem to the end of this point cloud.
Public methodAsReadOnlyListOfPoints
Returns an enumerator and list indexer over point cloud locations.
Public methodClearColors
Destroys the color information in this point cloud.
Public methodClearHiddenFlags
Destroys the hidden flag information in this point cloud.
Public methodClearNormals
Destroys the normal vector information in this point cloud.
Public methodClearPointValues
Destroys the extra value information in this point cloud. Extra values can be used to store a user-defined values, such as intensity.
Public methodClosestPoint
Returns index of the closest point in the point cloud to a given test point.
Public methodCreateContourCurves(Point3d, Point3d, Double, Double)
Creates a planar curves by intersecting a plane with a point cloud.
Public methodCreateContourCurves(Point3d, Point3d, Double, Double, Double, Double, Boolean, Boolean, Boolean, Double)
Creates a planar curves by intersecting a plane with a point cloud.
Public methodCreateSectionCurve(Plane, Double)
Creates planar curves by intersecting a plane with a point cloud.
Public methodCreateSectionCurve(Plane, Double, Double, Double, Boolean, Boolean, Boolean, Double)
Creates a planar curve by intersecting a plane with a point cloud.
Public methodGetColors
Copy all the point colors in this point cloud to an array.
Public methodGetEnumerator
Gets an enumerator that allows to modify each point cloud point.
Public methodGetNormals
Copy all the normal vectors in this point cloud to an array.
Public methodGetPoints
Copy all the point coordinates in this point cloud to an array.
Public methodGetPointValues
Copy all the extra point values in this point cloud to an array. Extra values can be used to store a user-defined value, such as intensity.
Public methodGetRandomSubsample(UInt32)
Returns a random subsample of a point cloud.
Public methodGetRandomSubsample(UInt32, CancellationToken, IProgressDouble)
Returns a random subsample of a point cloud.
Public methodGetUnsafeLock
Allows the developer to obtain unsafe pointers to the underlying unmanaged data structures of the PointCloud.
Public methodInsert(Int32, Point3d)
Inserts a new point into the point list.
Public methodInsert(Int32, Point3d, Vector3d)
Inserts a new point into the point list.
Public methodInsert(Int32, Point3d, Color)
Inserts a new point into the point list.
Public methodInsert(Int32, Point3d, Vector3d, Color)
Inserts a new point into the point list.
Public methodInsert(Int32, Point3d, Vector3d, Color, Double)
Inserts a new point into the point list.
Public methodInsertNew
Inserts a new PointCloudItem at a specific position of the point cloud.
Public methodInsertRange
Append a collection of points to this point cloud.
Public methodMerge
Merges, or appends, a specified point cloud into this one.
Public methodPointAt
Returns the location of the point at a specific index.
Public methodReleaseUnsafeLock
Updates the PointCloud data with the information that was stored via the PointCloudUnsafeLock.
Public methodRemoveAt
Remove the point at the given index.
Public methodRemoveRange
Removes points at given indices.
Public methodShrinkWrap
Returns a ShrinkWrap mesh from this point cloud object.
Top
See Also