Click or drag to resize

PointCloudAddRange Method (IEnumerablePoint3d, IEnumerableVector3d, IEnumerableColor, IEnumerableDouble)

Appends a collection of points, normal vectors, colors, and extra values to this point cloud.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.5
Syntax
public void AddRange(
	IEnumerable<Point3d> points,
	IEnumerable<Vector3d> normals,
	IEnumerable<Color> colors,
	IEnumerable<double> values
)

Parameters

points
Type: System.Collections.GenericIEnumerablePoint3d
Points to append.
normals
Type: System.Collections.GenericIEnumerableVector3d
Normal Vectors to append.
colors
Type: System.Collections.GenericIEnumerableColor
Colors to append.
values
Type: System.Collections.GenericIEnumerableDouble
Exta point values to append. Extra values can be used to store a user-defined values, such as intensity.
See Also