Click or drag to resize

PointCloudAddRange Method (IEnumerablePoint3d, IEnumerableVector3d)

Appends a collection of points and normal vectors to this point cloud.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public void AddRange(
	IEnumerable<Point3d> points,
	IEnumerable<Vector3d> normals
)

Parameters

points
Type: System.Collections.GenericIEnumerablePoint3d
Points to append.
normals
Type: System.Collections.GenericIEnumerableVector3d
Normal Vectors to append.
Exceptions
ExceptionCondition
ArgumentExceptionthrown if points and normals have differing numbers of elements
See Also