Click or drag to resize

PointCloudUnsafeLock Class

Permits access to the underlying PointCloud raw data structures in an unsafe way.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryPointCloudUnsafeLock

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class PointCloudUnsafeLock : IDisposable

The PointCloudUnsafeLock type exposes the following members.

Methods
  NameDescription
Public methodColorArray
Retrieves a pointer to the raw array of colors, which are represented as 32-bit integers in ARGB format, or null if none is available.
Public methodNormalArray
Retrieves a pointer to the raw array of point normals, or null if none is available.
Public methodPointArray
Retrieves a pointer to the raw point array, which uses coordinates defined with double precision floating point numbers, or null if none is available.
Public methodRelease
Releases the lock and updates the underlying unmanaged data structures.
Public methodValueArray
Retrieves a pointer to the raw array of point values, or null if none is available.
Top
Remarks
This lock object needs to be disposed before using the PointCloud in other calculations and this can be achieved with the using keyword (Using in VB.Net).
See Also