Click or drag to resize

PointCloudUnsafeLock Methods

The PointCloudUnsafeLock type exposes the following members.

Methods
  NameDescription
Public methodColorArray
Retrieves a pointer to the raw array of colors, which are represented as 32-bit integers in ARGB format, or null if none is available.
Public methodNormalArray
Retrieves a pointer to the raw array of point normals, or null if none is available.
Public methodPointArray
Retrieves a pointer to the raw point array, which uses coordinates defined with double precision floating point numbers, or null if none is available.
Public methodRelease
Releases the lock and updates the underlying unmanaged data structures.
Public methodValueArray
Retrieves a pointer to the raw array of point values, or null if none is available.
Top
See Also